HACS and mini_graph-card

Hi, Im brand new to Home Assistant, using HASSIO.

I know this question is stupid, however after using significant time to look for explanation, I need some basic help. Please bear with me.

I have HASSIO installed, working. Update to latest version. I have HACS installed, and it seem to work as expected. I can install frontends, and it looks like it is working. I have installed the frontend called “mini_graph_card”.

I have added a manual card in Lovelace. I have put in the below text in the card configuration (I have tried with many other versions also, all give the same error)

  • type: ‘custom:mini-graph-card’
    • sensor.network_throughput_in_eth0

No matter what I put into the configuration I get the same error, like this

No card type found

  • type: ‘custom:mini-graph-card’
    • sensor.network_throughput_in_eth0

I actually belive I have missed something in the configuration of using the HACS or mini_graph_card, however I can not figure out what.

Any ideas? I know im stupid:-)

Hi and welcome to the forum. Can you please have a read of point 11 here then edit your post to correct the formatting?

formatted code would really help, as already mentioned by tom_l
Or screenshots…then we know in which part of the Lovelace you are

if you are in the lovelace card editor (where you edit the config for a single card and do not have the UI), “type” and “entities” both start in column 1 and type is not prefixed by a hyphen

type: 'custom:mini-graph-card'
  - sensor.network_throughput_in_eth0

The samples for this card on github show it with the hyphen and indented, that’s for direct copy&paste (+ adjusting indentation) when you edit Lovelace config with the raw configuration editor ( where you see the yaml for the whole board in one file, including all the formatting).


Armin-gh, That worked perfectly, as mentioned Im very new to HASSIO/Lovelase. Thanks.

Tom, I will in the future use formated code. Thanks for showing how it’s done.

1 Like