HACS Blue Iris Integration - Nothing discovered

I have installed the HACS integration called “Integration with Blue Iris NVR” recently and kept it upto date (currently installed at version 28e9e00".

I am running Hass.io with Home Assistant at version 0.105.3

I added the integration, then had to manually add it via Configuration --> Integration --> Add

I entered the IP address of my Blue Iris web server, the port and a user name and password

However nothing further happened after clicking OK, I have nothing visible in the integration at all. I set the advanced settings on the web server as per the instructions, but to no joy.

I can happily get to the UI3 interface (which prompts for username/password) via the web url of htttp://192.168.0.xx:xx/ui3.htm

Anyone got any ideas or having a similar issue?

same issue here… no camera’s or other entities came into HA after i added the integration and entered my Local IP of my blue iris.

Hopefully someone else has cracked it and can give some suggestions

I just updated the integration yesterday and restarted and all the cameras and sensors are there now! Odd

How did you even add it? I used HACS, restarted HA, Configuration-Integrations doesn’t show it, and under Add it’s not listed, it goes from Axis to Brother (and I looked at the whole list). How did you get it to show up at all? I’m on 105.3 as well.

Well… I ended up with a system reboot (not just server restart), then I re-installed, then I restarted HACS, then I restarted HA… about this time the integration showed up in the Add dialog.

There’s something broken or delayed in getting it to show up.

I have a ton of new things showing in the integration, need to now work through and see what all they do.

Exactly the same with with 994c6e7 and so far, no tweaking, rebooting or sacrifices to the dark gods have returned any joy. Sure would love to see B.I. work with this, though, it looks stellar.

I saw on github that there was a breaking change last month with the update for v5 JSON API. I am still on v4. Does anyone know if the plugin still works with v4? I am having trouble with the setup screen as well.

Since you said that mchiass, I fired up an old PC that still has v4 on it, and sure enough, it works like a champ! Now we are getting somewhere - the issue is between v4 and v5.

What version of the plugin are you running? I have tried but can’t get past the “Set up Blue Iris” window. No arrangement of ip addresses and credentials will allow me to get past the “Invalid server details”.

I have the same issue with v5. With v4, it installed right away.

I am running the version labeled as 994c6e7 the newest one posted.

That is the version I have and am running BI v4. But I keep getting “Error cannot connect to host” in the HA logs when I try to run the integration step.

I validated the IP, port, username and password were all correct.

Aside from clicking the “install” button, did you do any other prep work before you keyed in everything on the integration window?

None, I was getting repeated failures trying the v5, so I pointed it at the v4 install and it came right up.

I should probably also mention that the B.I, v4 install is on the same hardware as HA, but HA is running in a VBox, the .vmdk distro. I can reach the BI v5 server from this box.

If you can think of any way that we can narrow down why v4 is working here and not there, say the word and I will try it and post here. Hopefully we can get you running - in fact, hopefully, we can get v5 running.

Both HA and BI are running within separate VMs on my ESXi box. HA is running on Ubuntu and BI is Win10.

Thinking it is something with Win10. I can’t connect to the BI web server from other devices either.

Figured it out. Stupid Windows had listed the network connection as being “Public”, not “Private”. So it thought the computer was out in the wild not on my protected LAN. Once I switched the type everything synced up.

I was just about to chime in – I’m running it on the latest windows 10 and latest V5 BI without issues; when it requested I re-integrate to encrypt the password it came up within about 10 seconds.

Good deal mchiass, glad it is working.

Linwood, is that v4 or v5 you are working with? I still can’t get v5 up, but given what mchiass just said, I will check the Windows firewall.

Firewall was off, as expected. Still no idea why v5 won’t connect. I would love to be able to use it, since it has all my latest configurations and cameras.

Does anyone have v5 running with HACS Blue Iris Integration?

Linwood, is that v4 or v5 you are working with?

Yes, it’s V5, I am new to BI and so started on V5.

I used HACS version of this. I recall when I first tried it having trouble making it appear in the available integrations lists, but your problem appears to be (if I understand) you can add the integration and then nothing happens?

My BI and HA are on different subnets on my LAN, are yours? His instructions say to set the account created to administrator and “LAN only”. Don’t use the latter if yours are different also.

And you are using the web server’s internal LAN address, not trying to use an external address (e.g. settings, web server, local not remote). Sorry if that’s obvious.

Do you know how to use Wireshark? You might monitor for port 81 (assuming that’s where you are running BI) coming from your HA IP address, and see what the session looks like – does it even connect and exchange data (reading the guts of the data may be a bit painful but you might at least see if they are talking).

You also might try adding this to configuration.yaml (if you use it; if not no idea how debug works):

  default: warn
     custom_components.blueiris: debug 

It’s been a while but if I recall you get quite a bit of detail from that in the logs (under HA’s developer logs) though when I used it I was looking at the sensors not at the initial connections.

Another technique to see if the port is open, though it depends on how you have HA installed, is ssh into HA and see if the port is open to the system running BI:

 ferguson@ha:~$ telnet 81
Connected to watch.leferguson.com.
Escape character is '^]'.

Now show of trying to fake some http commands you cannot DO anything at that point but exit with the escape command and quit, but if you can’t get a successful connection you might get a clue why from the error. Make sure the TCP path to the port is clear of any filtering, routinging issues, etc.

Oh… use IP for BI not DNS names inside of HA. They broke a lot of names with HA (not BI) in a release a few months back by trying to “help” with local dns caching, to me DNS names no longer work reliably inside of HA.

Thank you for being so helpful, I really do appreciate it.

I can SSH into HA and see port 81 open on the B.I. v5 box using nmap, so it sees the port open. I have tinkered with the Blue Iris web server and user settings back and forth, but no joy so far.

I am having the same problem that you were, I cannot add the integration. It keeps telling me my server details are invalid. When I use the IP of the Blue Iris 4 install, it goes right in, so I was thinking it was a v4 vs. v5 issue, but since you are using v5 successfully, that isn’t it.

I am going to put Wireshark on this (HA) machine and look for traffic back and forth. If I learn anything, I will post it here for posterity - even if it turns out to be a bonehead simple error on my part. My pride is broke, mate. :slight_smile: