HACS Custom Card not showing in Lovelace

I am doing a new install of HA and am having the following issue with the Custom:Weather card. I assume the screenshot below is showing it attempting to load. I have Weather Card installed via HACS but when trying to use it by calling it in a manual card type, I get an error saying that the “Custom element doesn’t exist: weather-card”. It is definitely installed and available. I have both HA instances up side by side and it is working in my old instance, but not the new. Looking at file editor side by side I see no differences. Thoughts?

I am having the same issue with any HACS cards…

I have the same problem here.

I have the same problem but on the frontend… it’s constanly telling me that Custom Element does not exist. I let it run and when I wake up it’s there… I have no explanation for that. It’s happened twice now… I just let it run and it seems to figure itself out. Going through that right now that’s why I’m here trying to figure out why… I installed the Zigbee network card… says it doesn’t exist…

Restarting doesn’t work… rebooting doesn’t work… it just finally shows up. I have no idea why it does that.

1 Like

I’m having the same issue. HACS is installed, the custom card is installed in the Frontend section, going to the Resources menu in the Dashboards settings shows it was added automatically by HACS, but it refuses to show up in Lovelace, and manually messing with the Resources doesn’t help at all. I feel like I’m going mad.

EDIT: I played around some and it turns out it was just the first HACS card I installed, roku-card. I installed mini-media-player and rgb-light-card and they seem to be working fine.

Having the same issue here with Hacs installed surveillance-card. 14 other cards installed find. This one installs fine but is not available when adding a card. Just is not there with all the other available hacs installed custome cards. New HAOS install. Reboot hardware no help.

I am having the same issue as well. I just installed the digital clock and it is not showing up as an available card on the dashboard.

Same issue here. After downloading the card from HACS, I can not install it on my dashboard. This problem came up with the 2023 version.

I was having the same issue with the Custom Card no showing, reboot wont fix it… I did this and then I saw all the missing card…
Go to Setting, Devices & Service, Hacs
Then Configure , check the “Enable experimental features” Box submit.
It then restart Hacs (might be enought to fix it not sure)
Then I was seeing the card missing. (and was able to add card with yaml texte…

Hope it help someone!


I’m having this issue, last night and today. I first managed to get it back from a backup that was 3 days old and recreated from their, however it has happened again today where none of my custom hac frontends are showing up.

I tried the suggestion above, mine was already ticked as enabled.

I tried backing up from a backup after yesterdays fiasco, from a working version 6 hours ago, no joy.
Any help?