HACS doesn't work anymore after 2021.4.3 update. Is there an alternative?


I’m having troubles with HACS and I’m very close to giving up on it.
I run hassOS on rpi4 and HACS was working fine until I updated Home assistant to 2021.4.3 few days ago (I updated since then and I’m on 2021.4.6 now).
Since then HACS cannot start. I reinstalled hassOS but still cannot install HACS. It complains it cannot access pypi to download and install
the latest hacs frontend package.

I tried opening an issue on the HACS github page but it was closed, saying those are network problems on my end (although I can download other addons, and ping pypi from within my hassOS, so the network seems to be ok).

So, as I see it there are two last things I can do. Those are my questions:

  1. I would like to get to the OS shell and try installing those packages myself and see if I can fix it. But it seems that when I use a terminal addon
    it seems i’m in the wrong container. I see the config directory but I cannot run pip install or pip update. How can I connect and manually run the pip commands ?

  2. If 1 is not possible, how can I manually install addons/integrations that are normally installed by HACS (If I download the source code from their git page) ?

Thank you


  1. Read here.
  2. Most of the custom integration provide how to install them manually.

BTW: I’m having no issues with HACS in 2021.4.x.


Have you tried downgrading to the last known working version to see if it is working again? Just to be sure nothing else is causing this?

You are probably having other errors that prevents HACS from being loaded. Try resolving all your errors (if you have them) and try again.

HACS doesn’t provide add-ons.

It only provides custom integrations/plugins/themes/appdaemon apps.

Those are completely different categories of things.


I managed to install all the addons I needed manually. thats good enough for now.