Hacs not appearing

Hi Guys, new to HA, so was hoping to get some help.
Im trying to install hacs, went through the instructions and it seems to have installed correctly (i think)
On visual studio i can see the folder structure under custom components hacs is there along with the other stuff, api, front end etc…

But when i go to integration i cant seem to find it. Any help Please :frowning:

I tried installing it both via the ssh terminal and the visual studio terminal, it says it already exists but cant seem to locate it under intergration.

Thanks

hacs.zip 100%[=====================>] 828.54K --.-KB/s in 0.06s

2021-11-25 11:09:15 (13.4 MB/s) - ‘hacs.zip’ saved [848422/848422]

WARN: HACS directory already exist, cleaning up…
INFO: Creating HACS directory…
INFO: Unpacking HACS…
INFO: Removing HACS zip file…
INFO: Installation complete.

INFO: Remember to restart Home Assistant before you configure it’

Screenshot 2021-11-25 at 22-21-26 Configuration - Home Assistant

lol yeah ive been there and tried adding it, doesnt appear on the list

As he said he couldn’t find it under Integrations, I don’t think that pointing him to the Integrations button is helping much.

I’m a fairly new HA user as well and I can tell you that you’re not the only one who have this issue. I’ve been installing HA in various forms perhaps 10 times (for the learning experience) and I’ve had the “HACS does not show up under Integrations” issue every single time.

My take is that there are some issues in HA that many/most users experience but that never seems to get fixed. It’s really frustrating to google the issue only to see that the exact same thing has been reported and discussed over and over again for years without ever having a solution, or even a confirmation that there is an issue at all. Most such bug reports are automatically closed after a while due to inactivity without getting resolved.

This particular issue (xxxx does not show up under Integrations) has been around since at least 2019 (e.g. Not finding HACS under Integrations in Homeassistant · Issue #851 · hacs/integration · GitHub). Sure, sometimes it’s user error but definitely not in all cases. I’ve never seen any real solution. My advise is just the generic things like clear the browser data, do a few shift+f5 reloads, open Network Monitor (ctrl+shift+e if Firefox) and check the “disable cache” box and reload, try a different browser, restart HA and/or the host, and so on… This seems to fix things for some users after a while. You can often see users saying “oh, it works now, I don’t know why but HACS suddenly shows up”.

By the way, it’s not just HACS, you’re going to see the same thing with other integrations every now and then. Various caching issues in other areas are likely going to play games with you as well.

em4d actually said:

It was not clear if the original poster was expecting it to be installed automatically and visible in the list of installed integrations or missing from the list of available to install integrations. I was just checking this.

Now the issue is much clearer. So yes, it did actually help.

Clear your browser cache or use another browser and see if it shows up when you try to intergate it.