Hacs not shown but installed

Hello Forum,
i am new in Home Assistent, installed it under an VM on Synology and verything is working since now, did not that much but Hacs dont get shown in devices, i tried also the method to cjange the Version, like discreibed by Git but bothing changed.
In notification there is an Info for a new “device” but i do not get the connection.
What to do, what will be needed to get more infos. as i told i am complete new, but experianced in software and a bit programming.
Thanks in advance

You did follow this first?
Download | HACS

Thank you for the feedback.

As i wrote, i did the way like in Git recommended:

Go to the Terminal and download the install script but do not execute it right away:
wget -O hacs.sh https://get.hacs.xyz
Edit the hacs.sh file with your preferred text editor.
In line 65 replace de download URL to version 1.33.0 and save:
wget “https://github.com/hacs/integration/releases/download/1.33.0/hacs.zip
Run the updated install script:
bash hacs.sh
Restart HomeAssistant.
Follow the usual steps for activation (About the “Submit” button you mentioned, the documentation is outdated, there’s no such button anymore).
Update HACS in the usual manner.

So i had have ssh connect, but, the error seems not new, don’t understand, that there is no solid solution after this long time the problem exists.
Maybe it depends on the HA OS, its the newest version i installed yesterday.

Do you refresh the browser? I assume when you say it is not shown, you mean it is not shown in the sidebar. That just means you need to refresh the browser so that it updates it’s cached version of the webapp - as long as HACS is showing in the devices page.

Thank you, this i did, i searched for the problem in the net, find some tipps and tried this. clean cache, restart the synology, in the notifications is an “1” for some new devices, but hacs not there, and in the sidebar it could not be if its not in devices because i do not come to the settings.
Can i find the error if i can activate a debug mode?

? I have no clue why you did all that, the link points clearly to something else ?
I have installed hacs on 5 servers all different (container/super/haos) and always following the url/path I added, no editing nothing. I also did not point to any ‘git’ so not alt all sure why / what you did

EDIT … will do a full reinstall on my 218+ now to see if there is anything fishy with then new HAOS…not much mem so will take a while

I did that, because there are many people have the same problem, and try to find an solution, and if its recommended in Git, i thought this is the place where a solution will be happend.
The problem seems to be known since older HA Versions. But i don’t know, i am a newbie, and get everything running, without hacs.
Thanks for your support.

So, brand new install from ova file
then installed SSH add-on and entered the terminal

wget -O - https://get.hacs.xyz | bash -

went to settings > devices and installed hacs, ticked the boxes, clicked submit
then got the screen to open git and pasted the code…authorized it and then…
All fine

Thank you for your support, i deinstalled hacs and installed it again, now its finding in the integrations.
Now i am going deeper into HA.
Think there are some more questons, get also the ios app running, was also not that easy, have to deactivate privat WiFi, otherwise the app will not get running without problems.
It is a complex thema, but if you come inside then it will become easier.
THX for support