HACS Store on Docker

Does anyone have installed the HACS Store on Docker?

If you mean do I have HACS running in a HA Container install method then yes, I do.

Yes, I mean an installation on Synology Docker. How did you install this version?

I copied the folder hacs to my custom_components installation on my synology diskstation from this site:
integration/custom_components at main · hacs/integration (github.com)

But I’m not able to integrate HACS.

Do you have an idea why?

Well, I originally installed HACS a long time ago when it was configured thru yaml. And at that point I just needed to copy the hacs folder to custom_components as you have done.

Things may have changed so that manual download won’t work. But I kind of doubt it. manually copying the file should still work as far as I know.

What does that mean?

Have you restarted HA after you manually downloaded the folder?

does it still not show up in the list when you select “add integration” from the integrations page?

something else?

Thank finity, with an older version, it works without problems. With the latest version I got an error.

About 3 days ago I installed Home Assistant on Docker for the first time and there was no HACS on my end either.

The Solotion:

  1. SSH into the Home Assistant container
  2. execute: wget -O - https://get.hacs.xyz | bash -

Perhaps the command will change over the time. I found the actual command on the website hacs.xyz under “Download”:

1 Like

That is expected, with the exception of DietPi (who now includes HACS for some reason) no installation have that.
You are required to manually download and configure it.

hi @feron,
i’m having these problem:

Which version is work for you?

Thanks

I moved my home-assistant from a Raspberry Pi (where it worked fine a long time) to a docker inside Synology. But this docker version is limited compared to the “normal” install, regarding adding custom components or similar. That’s I try to install HACS, but what should I do, regarding the missing ‘unzip’? How to install?

Is my way the right way at all (SSH into the Synology, going into the containers folder, …)

ad@DS923plus:/volume1/docker/homeassistant$ wget -O - https://get.hacs.xyz | bash -
--2024-01-15 16:12:06--  https://get.hacs.xyz/
Resolving get.hacs.xyz... 104.21.39.42, 172.67.143.44, 2606:4700:3031::ac43:8f2c, ...
Connecting to get.hacs.xyz|104.21.39.42|:443... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://raw.githubusercontent.com/hacs/get/main/get [following]
--2024-01-15 16:12:06--  https://raw.githubusercontent.com/hacs/get/main/get
Resolving raw.githubusercontent.com... 185.199.108.133, 185.199.111.133, 185.199.110.133, ...
Connecting to raw.githubusercontent.com|185.199.108.133|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 4525 (4.4K) [text/plain]
Saving to: 'STDOUT'

-                                                                100%[========================================================================================================================================================>]   4.42K  --.-KB/s    in 0s

2024-01-15 16:12:06 (97.2 MB/s) - written to stdout [4525/4525]

ERROR: 'unzip' is not installed
ad@DS923plus:/volume1/docker/homeassistant$

I found some instructions here:
https://www.reddit.com/r/homeassistant/comments/munj6h/cant_install_hacs_in_homeassistant_in_docker_on/