HACS stuck 'waiting for device activation'

Thank you, worked perfect with downgrade.

Chiming in to say this worked for me too, thanks very much! I’m using the container version of HA, so I had to

docker exec -it homeassistant bash

first to log into the container. If that helps anyone!

This works perfectly

I’m hitting this too.

Absolute beginner so all of the above might as well be another language.

I have Home Assistant set up in UTM on a Mac Mini.

Any help would be great.

1 Like

Worked! Thanks

Try downgrade the hacs version, as Vinay told:

  1. Go to the Terminal and download the install script but do not execute it right away: wget -O hacs.sh https://get.hacs.xyz
  2. Edit the “hacs.sh” file with your preferred text editor.
  3. In line 65 replace de download URL to version 1.33.0 and save: wget "https://github.com/hacs/integration/releases/download/1.33.0/hacs.zip"
  4. Run the updated install script: "bash hacs.sh"
  5. Restart HomeAssistant.
  6. Follow the usual steps for activation (About the “Submit” button you mentioned, the documentation is outdated, there’s no such button anymore).
  7. Update HACS in the usual manner.

That worked for me! Thank you!

kesin çözüm. teşekkür ederim

Created account to like this.

Worked for me! thank you!

I succeeded in activating the github integration, and il have this screen appearing :

I tried several times full new installations of HA and Hacs, and it is always the same … Can you help me ?

PS; I have updated Hacs and HA to the last versions.

That helped me too. Thanks!

I’m experiencing the same issue. I installed HACS yesterday following the instructions on the official HACS website. Should I uninstall this version before following the instructions provided by @vinay01joshi ?

Great thanks! it works

How to edit “hacs.sh” file. Is the file somewhere in the directory?

This has been a wasted morning. I’ve tried several solutions mentioned in this thread w/o success. Have the authors of HACS addressed this issue?


Just done another Home Assistant update for May 06 version, (Backup and Update) - HACS loaded after that … maybe it could work for you now?

I finally got it loaded. I used the script hack to drop back a version for the install and did the update after.

No you can just follow the instruction .

use vi editor.


but I have a problem after starting the script via SSH on NAS
ERROR: 'unzip' is not installed
I am with HA Container on docker under DSM Synology…

EDIT: it’s OK. I opened a terminal in docker Home Assistant and got

homeassistant:/config# bash hacs.sh                                              
INFO: Trying to find the correct directory...                                    
INFO: Found Home Assistant configuration directory at '/config'                  
INFO: Changing to the custom_components directory...                             
INFO: Downloading HACS                                                           
Connecting to github.com (                                      
Connecting to objects.githubusercontent.com (                
saving to 'hacs.zip'                                                             
hacs.zip             100% |*********************************| 3910k  0:00:00 ETA 
'hacs.zip' saved                                                                 
WARN: HACS directory already exist, cleaning up...                               
INFO: Creating HACS directory...                                                 
INFO: Unpacking HACS...                                                          
INFO: Verifying versions                                                         
INFO: Current version is 2024.5.1, minimum version is 2023.6.0                   
INFO: Removing HACS zip file...                                                  
INFO: Installation complete.                                                     
INFO: Remember to restart Home Assistant before you configure it