HACS - You have 1 Lovelace elements that are not loaded properly in Lovelace

Add it to ui-lovelace.yaml

resources:
    - url: /community_plugin/lovelace-fold-entity-row/fold-entity-row.js
      type: js

What fixed it for me was removing the extra stuff on the url in resources. I had ?v=xxxx on the end of all my url lines which used to be to make sure you got changes loaded. When I removed that from all the urls, HACS no longer shows the cards as not loaded.

2 Likes

@Bmounir, I think the information should go to the configuration.yaml. At least I do.
@brucehvn, yes indeed, that did the trick for me as well :-). Thanks!
The ?vxxx was once considered as a best practice. Not any longer it seems. Anyone with a clear view on this?

Ok had same problem with 1 card (mini media player). This fixed it for me:

  1. uninstall using HACS
  2. remove folder from www/community/…
  3. remove resource link from configuration.yaml
  4. reboot HA
  5. install component using HACS (check the folder is added in www/community
  6. add the resource line back to configuration.yaml
  7. reboot HA

Hm… just had the same issue. Uninstalled everything, restarted HA and not in HACS I can’t find my Lovelace plugins any more (e.g. mini-graph-card…)
Any idea how I can get them back?
Cheers,
Georg

In HACS you need to add them using the orange “+” in the bottom right

exactly this. The issue started today and random cards seem to be affected. Rebooting/restarting did not help, so I did a reinstall of all the cards, which worked.

1 Like

Same issue

I just looked at the module GUI, saw which ones weren’t there, and guessed their names from the others, and added them in manually. Also reboot HA, refresh browser tab might help sometimes…

Same problem all the sudden. Removed HACS and reinstalled from scratch. Ended up in the exact same place. Because of this HACS is entirely unusable. Anytime I add/remove a card some other card breaks. Right now “Weather” card won’t load because I uninstalled mini-media-player.

1 Like

This seems to be entirely related to running HACS behind a reverse proxy. I had recently told HA what my ‘external_url’ is and doing that seems to be what broke HACS. Removing my ‘external_url’ setting (letting HA guess,it gets the http protocol wrong) allows HACS to work fine again.

Hmm… I changed my internal URL to my external URL, because of HTTPS errors. My config:
External URL: https://***.duckdns.org:443/
Internal URL: https://***.duckdns.org:443/

This was it!