HACS - You have 1 Lovelace elements that are not loaded properly in Lovelace

I used a custom card and have now deleted it (tried also re-instaling it and delete it again). I have also checked the raw-file for the rotel-card.js entry, and in other pages contain the card, - which it does not.

Getting this message in HACS:

"Not loaded in Lovelace
You have 1 Lovelace elements that are not loaded properly in Lovelace"

And in the HA -log getting this:

"Tried to serve up '/config/www/community/rotel-card/rotel-card.js' but it does not exist"

How do I clean up HACS so I dont get the error message anyore?

Depends on how you use LL (storage, yaml), but have you looked in the resources?

I use the “Raw configuratiion editor”.
How do i look in the resources, do you mean hiden files in “.storage”, if so, what am I looking for?

Since 0.107.x i think, Configuratian -> Lovelace Dashboards -> Resources

Aha,- didnt chatch that one. Nice. Thanks!

I started getting this today for 17 elements not loaded properly. This is wrong as all my views are working properly. Refresh and reload resources make no difference. I use yaml and directories heavily.

same here, allthough 1 element

didnt add any elements last weeks, so no idea where this is coming from
maybe an bug with HACS?

Yup, the error message in HACS stayed put, but the HA log with the error went away.

i dont see any error at all in log file, just that message in HACS
how can i know what element is causing this?

ok , fould the culprit, i have a element installed, but not using anymore, and commented out in resources

In my case the resources had urls that started with /local/community/. While that works perfectly, HACS is looking for /hacsfiles/ instead.

I use hacsfiles and still have this message. And the card is working.
Any idea what’s wrong?

I had 2 elements that worked well in hacs:
1 - mini media player
2 - button-card
Today I am installing a third
3 - Binary Control Button Row
and I have the message
You have 1 Lovelace elements that are not loaded properly in Lovelace.
I uninstall it and the second item no longer works.
I uninstall it and the first item no longer works.
I uninstall and reinstall hacs and nothing works anymore

Looks like I’m in the same boat as everyone else now. HACS was saying the button-card was not loading properly so I tried to uninstall and install it again. Now it don’t work and I now have three that are not loaded properly.

button-card
card-mod
Mini Graph Card

I even rolled back to a snapshot from this morning and that did not fix anything. I assume that HACS is not part of the snapshot feature.

To work around the bug:
In configuration, Lovelace dashboard :
manual (re)write the resources

  • /hacsfiles/mini-media-player/mini-media-player-bundle.js Type Javascript
  • /hacsfiles/button-card/button-card.js Type Javascript

    According your cards
1 Like

Thanks. That worked

+1 - Lovelace card not loaded

Issue reported

Fix

So indeed … - url: /hacsfiles/ …

But is seems not to work for me. Existing resources keep work. Newly added, not loaded …

Someone else with the same experiences?

Same here today, suddenly 2 cards.
After re-install it was fixed.

1 Like

My configuration.yaml holds …

lovelace:
  mode: yaml
  resources:
  - url: /hacsfiles/spotify-card/spotify-card.js?v1
#  - url: /local/community/spotify-card/spotify-card.js?v1
    type: module
  - url: /hacsfiles/lovelace-slider-entity-row/slider-entity-row.js?v1
#  - url: /local/community/lovelace-slider-entity-row/slider-entity-row.js?v1
    type: module
#  - url: /local/community/restriction-card/restriction-card.js?v1
  - url: /hacsfiles/restriction-card/restriction-card.js?v1
    type: module
#  - url: /local/community/config-template-card/config-template-card.js?v1
  - url: /hacsfiles/config-template-card/config-template-card.js?v1
    type: module
  - url: /hacsfiles/vertical-stack-in-card/vertical-stack-in-card.js?v1
    type: module
  - url: /hacsfiles/mini-graph-card/mini-graph-card.js?v1
    type: module

I reloaded all cards in HACS. Reinstalled HACS. Rebooted. Still the same!?

Anyone? Or is it just me :slight_smile: