HADashboard and AppDaemon Error: WARNING Disconnected from Home Assistant, retrying in 5 seconds

I’m trying to install HADashboard, but I keep getting errors whenever I run it. I have the latest version of Hass.io and I’ve followed the instructions provided on the Home Assistant website, but I keep getting errors saying that AppDaemon was disconnected from Home Assistant. I also have DuckDNS with Let’s Encrypt setup. My internet provider has an issue where I can’t use DDNS hostnames from inside my LAN, but after adding a certificate exception in Firefox, I can use the Let’s Encrypt SSL with the IP of the server (

This is my logfile

starting version 3.2.2
2018-02-18 15:46:39.162296 INFO AppDaemon Version 2.0.8 starting
2018-02-18 15:46:39.163801 INFO Configuration read from: /config/hadaemon/appdaemon.yaml
2018-02-18 15:46:41.660313 INFO Got initial state
2018-02-18 15:46:41.663337 INFO App initialization complete
2018-02-18 15:46:41.665964 INFO Starting dashboard
2018-02-18 15:46:42.582405 WARNING Disconnected from Home Assistant, retrying in 5 seconds

My configs look like this

AppDaemon options

  "domain": ""


  cert_verify: False
  disable_apps: 1
  logfile: STDOUT
  errorfile: STDERR
  threads: 10
  app_dir: /config/hadaemon/apps
  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem
  ha_key: myhapassword
  dash_dir: /config/hadaemon/dashboards/
  dash_password: differentpassword

main.dash (Copied from setup guide)

## Main arguments, all optional
title: Hello Panel
widget_dimensions: [120, 120]
widget_margins: [5, 5]
columns: 8

    widget_type: label
    text: Hello World

    - label(2x2)

The URL that is supposed to be the HADashboard,, doesn’t load at all, and my browser just says it can’t connect. I’ve tried things I’ve seen in other posts about HADashboard problems, and they have gotten me from my initial “Can’t conenct to Home Assistant” to now saying “Disconnected from Home Assistant.” Any help with this would be great, and thanks in advance for any help.


you probably cant reach home assistent with your local address, because you have lets encrypt and duckdns integrated.

so your ha_url must be your duckdns address.

1 Like

That seems to get rid of the errors in the logs, but I still can’t go to the HADashboard page at I get an “Unable to Connect” message from Firefox.

Edit: After a minute or two, the errors about being unable to connect come back. No device inside my network can access DDNS domains that lead back to the network, only the internal IP’s.

if you cant access your home assistant with your duckdns from a browser then your setup is wrong.
if you have setup duckdns and letsencrypt the right way in home assistant, you cant reach your home assistant with http://local_ip:8123

the best way to go about this is to remove lets encrypt and duckdns from your home assistant.
then connect your dashboard to your local IP without https, but with http.

then install nginx as a proxyserver to connect to from the outside.

I can access Home Assistant through my duckdns name, just not on my home network. My internet provider blocks me from accessing my home network through my public IP from inside my network. I can only access my HA setup from https://mydomain.duckdns.org:8123 from outside my network, and, after ignoring the HTTPS error, from inside my network. With my current HADashboard configuration, I get an “Unable to connect” error in the logs when I try to use HTTP, and a “Disconnected from HA” error when I use HTTPS without verifying the cert, so I think that it’s able to find the HA server on my local network, just not connect properly.

You can confirm the exact error by running with the -D DEBUG flag.

Sorry if this is a dumb question, but how do I add flags to a Hass.io addon?

there is your problem.
you cant ignore errors in an addon.

like i said, the best way is to setup nginx, let your outside ip point to your nginx and then you can go to ha without https

Sorry if this wasn’t clear, but the HTTPS errors weren’t in the addon, but in my browser. After I tell my browser to not verify certs on that page, it works fine with HTTPS on. I added the option to AppDaemon config to ignore HTTPS certs, so it shouldn’t matter that it’s invalid for the IP.

You are running a very old version of AppDaemon - I don;t know for sure if the code to ignore certs is in there - you can try using --commtype SSE which uses a different code branch that used to work more reliably.

This code has also improved in the 3.0 beta if you want to give that a try, but beware of breaking changes in the upgrade.

1 Like

OK, I’ll try that out. Could you possibly link me to the beta or an installation guide for it? Thanks!

I’m not a hassio expert, but @frenck has built a hassio addon for AppDaemon 3:

Make sure you use the up to date docs, as the config file format has changed, there is a link in the post above.

1 Like

Thank you so much!

1 Like

Also, make sure you are running the latest version of HASS.IO - the appdaemon addon relies on some functionality introduced in the last month or two to work.

1 Like

I just updated HA last night, so it should be on the latest version. Thanks again for the help!

I just finished installing AppDaemon3 and it works perfectly now. Again, thanks so much for the help!