HADashboard disabled in Hassbian

I’ve just switched from hass.io to hassbian.
I’ve installed Appdaemon using hassbian-config install appdaemon
All seemed to go ok, but I can’t access the web interface on port 5050.
This is the output of my log:

2018-02-24 17:33:54.365349 WARNING Unable to connect to Home Assistant, retrying in 5 seconds
2018-02-24 17:33:59.379701 WARNING Unable to connect to Home Assistant, retrying in 5 seconds
2018-02-24 17:34:11.883241 WARNING Unable to connect to Home Assistant, retrying in 5 seconds
2018-02-24 17:34:18.578505 INFO Starting Apps
2018-02-24 17:34:18.764819 INFO Got initial state
2018-02-24 17:34:18.766459 INFO Loading Module: /home/homeassistant/.homeassistant/appdaemon/apps/hello.py
2018-02-24 17:34:18.783055 INFO App initialization complete
2018-02-24 17:34:18.784150 INFO Dashboards are disabled
2018-02-24 17:34:18.784753 INFO API is disabled
2018-02-24 17:34:18.927209 INFO Connected to Home Assistant 0.63.3

this is my appdaemon.yaml

logfile: /home/homeassistant/appdaemon/logs/applog.txt
errorfile: STDERR
log_generations: 3
threads: 10
app_dir: /home/homeassistant/.homeassistant/appdaemon/apps
ha_url: http://hassbian.local:8123
dash_url: http://hassbian.local:5050
dash_dir: /home/homeassistant/.homeassistant/appdaemon/dashboards

Error log shows:

File “”, line 969, in _find_and_load
File “”, line 958, in _find_and_load_unlocked
File “”, line 673, in _load_unlocked
File “”, line 673, in exec_module
File “”, line 222, in _call_with_frames_removed
File “/home/homeassistant/.homeassistant/appdaemon/apps/hello.py”, line 1, in
import appdaemon.plugins.hass.hassapi as hass
ImportError: No module named ‘appdaemon.plugins’

Not sure what I am doing wrong.

I got this sorted.
I appdaemon.yaml, hadashboard had to be HADashboard.

After fixing that I had a couple of issues with folders missing
Hassbian config created a folder in /home/homeassistant/appdaemon
From that the following folders were missing:

HADashboard now runs, next issue is to work out why the dashboard I had in hassio looks completely wrong in hassbian. non of the color settings are applied to widgets and some text doesn’t align the same.
It’s all a learning curve!

thats a skin problem.
some variables that are needed are not in the skin you use

Thanks. I’ve got it almost working.
When I ran in Hass.io, I had widget size as 60x60 and doubled most of these, so they were effectively like a standard 120x120 widget. This was so I could have front panel style displays that showed currently playing program, but the text now sits below the widget, css issue I suspect but don’t know where to change it. I changed it for my specific dashboard css but it keeps overwriting.
Will post pictures later it might explain better!

My other issue I’m left with is the dashboard isn’t updating in hassbian, and I can’t turn lights on and off from it.
Slow but steady progress :slight_smile:

make your skin work (by adding the right variables to variables.yaml) and then the dashboard looks like you had it.

Thank you. I shall give that a try when I got home from work later. Really appreciate the assistance.

1 Like