HADashboard not recompiling

Hoping someone can point me in the correct direction or tell me if I am just doing it wrong, lol. Tried searching but can’t seem to find this particular issue.

I installed Hass.io on Raspian Lite following the alternate install method which I believe has Hass.io running in a docker.

I installed the AppDaemon from the built in add-on store. It seems to launch just fine and does load up new dashboards but I cannot get it to recompile dashboards if I make any changes.

I am wondering if this add-on was meant for the standard Hass.io install or if using it as I am should still work ok.

Some of the things that I noticed that got me wondering are:

  1. In the appdaemon folder there appears to be a broken symlink for the compiled folder. It should link to /data/compiled but that folder does not exist. Manually creating it does not fix the dashboards not recompiling.
  2. I have tried 4 different ways to have it recompile and none seem to work:
    i - Just changing the dashboard file
    ii - Setting dash_force_compile to 1
    iii - Setting dash_compile_on_start to 1
    iv - Adding recompile=1 to the URL params.
  3. If I make a new dashboard it compiled it correctly the first time, but will not compile any other changes.
  4. If I removed a dash file, restart appdaemon from Hass.io config, and then put that dash file back in, it still shows the old version. So it seems that the compiled ones are being stored somewhere.

Logs all look clean. If anyone has anything to try please let me know. Thanks.

Just to update on this, it seems that it is actually recompiling and I see changes when I got direct to the dashboard within my home network. When I am external and using my external domain with nginx reverse proxy is when it seems to be caching and not showing the recompiled view. Pretty sure I have caching off but will need to double check. Have also tried Ctrl+R and Ctrl+F5 with no luck.

did u ever solve this?