HaDashboard won't display on older ipad after updating AppDaemon addon to 0.7.0

I have an older ipad running ios 10.3.3 and It displays HaDashboard fine with the AppDaemon addon version 0.6.2 that I am currently running but when I update to version 0.7.0 it won’t load the dashboard on this device. The dashboard loads fine on a PC though. Anyone else experiencing this?

Yess same here.

Good to see it wasn’t something dumb I did. I just restored from a previous snapshot and will wait for an update than, thanks.

Yess i did the same. Your welcome!

when will it be updated?

I have reported the official way a bug related to AppDeamon (0.7.0) Since a few weeks, the screens of the dashboard on an old iPad running iOS 9.3.5 remain empty. That is, the design of the screens is still visible. The gray squares, but there is no more information from sensors, no camera images and no weather report.
It is disappointing to note that no one seems to care about the bug I reported. Normally a bug that is reported is often fixed within a few days. Sometimes even within a few hours. But with AppDeamon it seems that everyone is pointing at someone else without anything happening. I noticed that this was the same issue a few months ago with exactly the same situation where the dashboards were also empty, and that Frenck seemed to be angry about it as well.
I wonder if such an app can still be an official addon then.
I am now stuck with an unusable iPad an expensive Vidabox (that is only suitable for this iPad) and a hole in the wall (to pull the power supply through).

I updated recently, and wish I’d seen this post first. =)
I was sure it was something dumb I’d done, as that seems to be my M.O.
Hope it gets resolved soon, as I use two older iPad2 tablets around the house, and now they are almost useless to me. Is it possible to just roll back AppDaemon without restoring a complete HA snapshot?

Same here, One useless IPAD 2 at my door. Awaiting for a solution :frowning:

Hi all,
are there any news regarding compatibility with iPad 2/3? Can I help in any way?

I have recompiled docker directly from https://github.com/home-assistant/appdaemon.git and the problem is solved.

Can you elaborate a little? I am running home assistant in a proxmox container but still have appdaemon and node red and such running as add-ons in home assistant (which I believe are really docker containers)? Did you recompile to use as an add-on for home assistant, or are you running in a full docker environment?

Since AppDaemon was updated, the dashboards are now visible on my Ipad 3

I run home assistant core in venv on Raspberry Pi OS and Appdaemon runs on a container. If you are using HASSOS, i think you just need to update the appdaemon addon to the latest version.

If you do not use HASSOS instead (in my case, I use the installation in venv and therefore I cannot use the addons) and you are using an ARM cpu, you have to proceed to create the container manually, as follows:

sudo docker rm appdaemon
git clone https://github.com/home-assistant/appdaemon.git
cd appdaemon
sudo docker build -t appdaemon --build-arg IMAGE=python:3.8-alpine3.12 --network=host .

sudo docker run --name=appdaemon -d -p 5050:5050 \
  --restart=always \
  -e HA_URL="http://<HA_IP_ADDRESS>:8123" \
  -e DASH_URL="http://$HOSTNAME:5050" \

Up and running now. Copied ’baseJavaScript’ from git dev to ’custom_widgets’

1 Like

Anyone facing issues with old devices, the solution posted on the Github website really helped and solved the problem.
You can do it with the File editor or using the FTP addon. If the mentioned folders don’t exist, just create them.

Blockquote copy content of directory appdaemon/appdaemon/widgets/basejavascript/ from github
to HA /config/appdaemon/custom_widgets/basejavascript
create /basejavascript as most likely it is not in custom_widgets
Restart Appdaemon

Source: https://github.com/hassio-addons/addon-appdaemon/issues/156

The “basejavascript” does not seem to work for me. I copied the files into custom_widgets/basejavascript folder (had to create it manually). In the log I can see the widget is loaded, but it actually breaks everything. Even on newest browsers no widgets are displayed.