HAOS 12.1 vs Raspberry Pi Zero 2 W - Keeps restarting every few minutes after standard install [solved]

This post is more for information than investigation, as I suspect Raspberry Pi zero 2 W’s are not the most highly recommended hardware for Home Assistant. But I equally believe that they should be OK for lighter-weight application implementation, experimentation and learning.

The Problem

So … I have 2 recently acquired Pi02W’s, which I attempted to install the latest HAOS 12.1 (RPi 3) upon - via Raspberry Pi Imager v1.85.

The installation process proceeds fine - but once at and past the initial user / location configuration - they both behaved badly, and what they had in common was multiple restarts - every few minutes.

I attempted some discovery / read many posts etc - and went through a process of trying different bits of hardware - predominantly with the first device.

OS: HAOS 12.1 (RPi 3)
SD Burn: RPi Imager 1.85 (via USB Stick / Laptop built-in)
PSU: USB Hub, USB Wall socket and various plug in chargers
Storage: SanDisk Ultra A1 128GB, Samsung Evo Plus 32GB, Integral A1 32GB
Network: Wi-Fi (various locations tried)
Browser: Desktop Chrome and Firefox from 2 different PC machines

On the first Pi02W device - I managed to install the SSH Terminal, but the Web UI was unusable and just kept on disconnecting every few minutes, reporting “Connection lost. Reconnecting…”

On the second Pi02W device - It seemed stable, but I could not install any add-ons, as it could not access Supervisor. I subsequently reinstalled, and Supervisor was present, but it then suffered the restarts.

Late in the game - I also utilised Observer on :4357 which reported all was OK, then subsequently not.


Eventually, in frustration - I tried installing HAOS 11.5 (32-bit) img.xz - and viola! Everything works as expected on both devices - with the same hardware that was previously used/tried.

Subsequently, (some days later), in experimentation - I tried installing HAOS 12.1 (32-bit) img.xz - and viola! Everything works as expected on the same hardware that failed previously.

OS: HAOS 12.1 (32-bit)
Core: 2024.3.1
Super: 2024.03.0
Front: 20240307.0

I have now also tried HAOS 11.5 (64-bit) and it fails. So - looks like HAOS 64-bit appears to be incompatible with RPi02W. I understand that it is generally advised not to run 64-bit on RPi02W anyway - due to its limited amount of memory. So - ideally, the RPi Imager should offer/select the 32-bit versions for the RPi02W, which is of course a Raspberry Pi Imager issue.


I did also attempt to install via Container and Core. Container was OK (as I remember), but the Core install did not complete due to issues with the Python 3.12.2 vs NumPy 1.26, and as neither installs have Supervisor (for Add-ons) - my efforts with them did not last long.

1 Like

Said so already in 2022

1 Like

HeHe. I did read that thread (amongst many), but missed that statement. Also I didn’t actually know at the time that the RPi Installer used the 64-bit HAOS binaries, as it does not state so on the installer. I think I assumed it was 32-bit and went on my merry way.