HAOS hangs after power failure / rescue shell not coming up

Have HA OS running on an old mac mini for a couple of month now without issues. Last night we had a power outage and HA didn’t start anymore.
Was trying to get into the rescue shell - no idea how to get to it…
Q1: any help on now to get into the shell (screen and keyboard attached - yes have checked forums/google/etc but no joy) ?
Finally booted into Ubuntu server on a USB stick and all the disks seam to be out-of-whack - after fsck and reboot everything works fine again :slightly_smiling_face:
Q2: how can I get to the logs to find out what went wrong (the logs on HA don’t really say anything) ?
Was brave enough to ‘kill’ it again just for giggles - same result. Then did a clean shutdown - same result… there must be something going on with the disk system under the hood.
Q3: how do I go about finding the culprit (am quite OK with linux/docker/ha but new to HA OS) ?

Forget about Q2: managed to get into SSH:22222 and look at messages from previous boots
Still leaves me with Q3
Anybody out there who can guide me a little bit ?

Having the same issues. Running on a small PC with a single mSATA ssd and it fails to boot anything from disk after a failed update.
If I could restore from a backup pre-update that would be great but I can’t access the disk.