HAOS VirtualBox : Unsupported system - OS-Agent issues


Latest update bring me this advertising :

Unsupported system - OS-Agent issues
System is unsupported because OS-Agent is missing, inactive or misconfigured. Use the link to learn more and how to fix this.

I run HAOS on VirtualBox without any problem before, how can i fix that ?


Same thing and even more errors after updating to 2022.11 on Docker installation:

I am also getting similar warnings:

Nothing ???

  1. This isn’t related to 2022.11. If you’re seeing these repairs in 2022.11 then your system was unsupported for the same reasons prior to 2022.11. You just didn’t notice because the warnings were hidden away, 2022.11 simply made what was already there more obvious. For a more detailed explanation of this, see here.

  2. Did you click the more info link in each one? It tells what is wrong and how to fix it.

Yes i searched but i can’t find a way to check if this os-agent is running or missing or anything but debian commands. I’m on VirtualBox.

From the link:

If the OS-Agent daemon is not running, start it. If the OS-Agent is not installed, you need install it.

Following that link brings you here. Which says to install it do this:

sudo dpkg -i os-agent_1.0.0_linux_x86_64.deb

And to test if its running do this:

gdbus introspect --system --dest io.hass.os --object-path /io/hass/os

Which of these did you try?

EDIT: Also I see “Unsupported system - Operating System” which means you are not using HAOS. What do you actually have in the virtualbox? And if you are using virtualbox anyway why not just use HAOS?

Actually, right under that it says:

Note: Replace the deb file in the above example with the file you have downloaded from the releases page.

And on the releae page you wil find OS-agent version 1.4.1, so the command would be as of today:

sudo dpkg -i os-agent_1.4.1_linux_x86_64.deb


I have HAOS on VirtualBox !
I don’t understand this new message, everything worked fine before.

Oh I’m sorry I was looking at a screenshot below your post. My fault.

What version of HAOS are you running? HAOS has come with OS Agent pre-installed and ready to go since v6.0, are you running on v5 or older? If not then perhaps try rebooting the machine, maybe something crashed.

No problem.
I have the lastest version : OS 9.3 / core-2022.11.1 / supervisor-2022.10.2.

Sans titre

Reboot change nothing.

No suggestions ? :sleepy:

Solved with a reinstallation with lastest image.

what does reinstallation mean? Like blow away your existing virtual machine and creating a new one? How did you restore all your settings?

I just started getting this error on on HA OS install a few days ago

1- make a full backup in HA.
2- delete your VM and create a new one with the latest image of HAOS.
3- restore your backup.