HAOS won't up- or downgrade; stuck on HAOS 10.1

Like the title says; My Pi is stuck on OS 10.1

I tried updating through the gui, through the ssh terminal, did te supervisor reload before updating, tried restarting host, tried to downgrade to 10.0 and 9.0. The proces starts normal, the Pi reboots, but I keep ending up with OS 10.1 (not changed)
There are no errors in the log of supervisor or host; no messages in the recovery console of HA.

HAOS is installed with HA image

Any suggestions? is there a way to do a clean install with ssh?

Thanks for your help

System Information

version core-2023.8.3
installation_type Home Assistant OS
dev false
hassio true
docker true
user root
virtualenv false
python_version 3.11.4
os_name Linux
os_version 6.1.21-v8
arch aarch64
timezone Europe/Amsterdam
config_dir /config
Home Assistant Community Store
GitHub API ok
GitHub Content ok
GitHub Web ok
GitHub API Calls Remaining 5000
Installed Version 1.32.1
Stage running
Available Repositories 1266
Downloaded Repositories 9
Home Assistant Cloud
logged_in false
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud ok
Home Assistant Supervisor
host_os Home Assistant OS 10.1
update_channel stable
supervisor_version supervisor-2023.08.1
agent_version 1.5.1
docker_version 23.0.3
disk_total 109.3 GB
disk_used 11.0 GB
healthy true
supported true
board rpi4-64
supervisor_api ok
version_api ok
installed_addons Z-Wave JS (0.1.87), Home Assistant Google Drive Backup (0.111.1), File editor (5.6.0), Terminal & SSH (9.7.1), Node-RED (14.4.5), Duck DNS (1.15.0), Samba share (10.0.2), NGINX Home Assistant SSL proxy (3.5.0), AdGuard Home (4.8.14), FiatChamp (3.0.8), Mosquitto broker (6.2.1)
dashboards 4
resources 3
views 12
mode storage
oldest_recorder_run 19 augustus 2023 om 16:05
current_recorder_run 22 augustus 2023 om 09:46
estimated_db_size 451.27 MiB
database_engine sqlite
database_version 3.41.2