Hargassner heating integration

This is fixed in the current version, please update your files from github.

1 Like

Thank you for the quick answer.
As far as I know, I used the latest files.

But I got it working fine by comment the line 7 out (#from apscheduler.schedulers.background import BackgroundScheduler).

Just for my understanding: Where and why apscheduler ist needed? For me, it works also without apscheduler.

Me once more.

Just figured out, that in my manifest.json apscheduler was missing in requirements. So I did not used last version. Sorry for that. Now it´s working. Thanks for your help and your work on the integration.

But the question why it works without apscheduler is still open.

Sorry if this has been covered and I missed it. Is it possible to use this integration “through” the Hargassner internet bridge? Or do you need the heating plugged in directly on the LAN and you can only have one or the other?
Thanks in advance.

Hi t2njgttn,

the integration uses telnet to get the data. So you need to connect the heating to your lan. But to push the data to the internet, the heating should have an internet-connection. In my case via my internet-router.

Still no change after update the integration and Home Assistant.

Getting these errors:

Logger: custom_components.nano_pk.sensor
Quelle: custom_components/nano_pk/sensor.py:220
Integration: Hargassner Nano-PK (Dokumentation)
Erstmals aufgetreten: 09:34:22 (106 Vorkommnisse)
Zuletzt protokolliert: 09:43:07

HargassnerStateSensor.update(): Invalid state.

and:

Logger: custom_components.nano_pk.sensor
Quelle: custom_components/nano_pk/sensor.py:143
Integration: Hargassner Nano-PK (Dokumentation)
Erstmals aufgetreten: 09:34:22 (106 Vorkommnisse)
Zuletzt protokolliert: 09:43:07

HargassnerEnergySensor.update(): Invalid value.

Any ideas? :frowning:

I have had also this problem. After investigation I recognized, that the heating made an update to version V14.1HAR.pr_FT. After update the hargassner.py with the parameters of the new version (as discribed in the github-readme → How to use with other Hargassner models or different firmware versions), it’s working as before.

Confirmed - Integration stopped for me several days ago as well - I just re-did the logging-part, entered my new DAQPRJ string and now it’s working again.

Fine to hear that your integration is working again.

Hello,
i tried to make this integration work today.
Could anyone please tell me where exactly i can find the firmware version of my Hargassner nano-PK heating?
I had a look at the options, but didn’t see it.
Thanks.

Following Error since HA Update. Any quick fixes?


Logger: homeassistant.helpers.frame
Quelle: helpers/frame.py:190
Erstmals aufgetreten: 18. Mai 2024 um 05:45:58 (3 Vorkommnisse)
Zuletzt protokolliert: 18. Mai 2024 um 05:46:19

Detected that custom integration 'nano_pk' accesses hass.helpers.discovery. This is deprecated and will stop working in Home Assistant 2024.11, it should be updated to import functions used from discovery directly at custom_components/nano_pk/__init__.py, line 42: hass.helpers.discovery.load_platform('sensor', DOMAIN, {}, config), please report it to the author of the 'nano_pk' custom integration
Detected that custom integration 'hacs' accesses hass.components.frontend. This is deprecated and will stop working in Home Assistant 2024.9, it should be updated to import functions used from frontend directly at custom_components/hacs/frontend.py, line 68: hass.components.frontend.async_register_built_in_panel(, please create a bug report at https://github.com/hacs/integration/issues
Detected that custom integration 'hacs' accesses hass.helpers.event. This is deprecated and will stop working in Home Assistant 2024.11, it should be updated to import functions used from event directly at custom_components/hacs/base.py, line 642: self.hass.helpers.event.async_track_time_interval(, please create a bug report at https://github.com/hacs/integration/issues

Ah… that Issue is already reported: