Harmony hub loses connection frequently

Slight over exaggeration there i think, but yes, i have said a few times i think / believe my network is good.
If you have any ideas or tips on what settings etc to check then id welcome them.
fyi, ipv6 is disabled

Im not using any kind of extender, just the stock ISP provided router.

Have you tried googling the router and harmony in the same search?

What I’m experiencing sounds similar. I had no issues until recently and I don’t know what has changed. I keep my HA on the latest version, so that is certainly an area of suspicion as it is updated frequently. I have 6 Harmony hubs. They all have XMPP enabled. My ISY/Polisy/Polyglot are having NO issues staying connected to them, but HA is. Again, this seems to point to something has changed with HA. I have no issues with pinging them either.

yes. returned nothing
its the stock ISP provided router from Sky

sounds very similar to my issue.
I changed from websocket method to XMPP and see no improvement.
The only thing that has changed within my setup is hassio.

again, not blaming home assistant, its just the most varying variable if that makes sense

FYI, upgrades to HA does not mean upgrades to harmony. There’s only been a few updates to harmony’s aoiharmony that occured on june 8th and a recent one in 0.113. Harmony firmware has updated ~5 times or so in that time period (they are silent updates). You can track all this information in HA by checking the integration on github and finding out when the manifest has been updated. Also, you can find out the firmware updates on logitechs website.

EDIT: I have to double check the silent updates. I might be mixing that up with Alexa.

Install a wifi analyzer on a phone or tablet and watch for ever increasing wifi signals that cycle over and over again. Usually every 30 seconds. This will interfere with connectivity of other wifi devices. Roku devices will do this when they can’t find the access point they are configured to use even if now hard wired. Also look for other wifi devices with very strong signals that may be drowning out your signal. If it’s only 6ft from the AP, it could be that the AP signal is too strong at that distance.

I’ve have 0 issues with my harmony hub disconnecting. They only issue I had was with a bug that was introduced in HA a few months ago that was causing harmony hub delays in sending commands. This has since been fixed.

Amy tips on an android app?
I have fing installed, but don’t see any way to monitor individual device signals?
I also have an issue with slow response times on the hub. At random.

The one I’m using is WiFi Analyzer by Abdelrahman M. Sid. WiFi Analyzer by farproc also works. The larger the arc for the device, the more powerful the signal. Look for overlapping channels and signals that start small then keep growing larger and larger then start over.

Ah yes. I’ve used both of those before.
But they don’t measure individual client signal, only the signal being received by the device it runs on.
Looking at the channel graph I see no overlap with other nearby networks and get a very stable signal when I place my phone on top of the Harmony hub

I don’t know of any android apps that will do individual clients. I’m guessing the wifi chips in cell phones don’t typically support monitor mode. I’ve used software that can do this on windows but when I was troubleshooting the wifi issues caused by roku, none of my internal wifi chips or usb dongles I could find supported monitor mode. No idea where the dongle went to that did support it.

Well…I thought mine was working fine. Then I remembered that over the last week or so, sometimes, my activity would show NOTHING instead of off, watch tv or watch roku. After checking the logs, HA had timeout errors but I restarted HA to the logs are gone. I’ll have to wait for it to happen again so I can post the logs. Previously, I just selected an activity and was good to go. Not this time. I had to restart HA.

I’m currently on 0.112.0. I had a lightning strike that damaged several pieces of electronic equipment in my house. I’ve been seeing a lot of strange issues since and I’m not sure if they are lightning related of the fact that I also re IP addressed my entire network three weeks ago as well.

I did some digging and it looks like this is related to some of my devices having trouble getting IP addresses from DHCP. I’ve seen this on multiple devices since the lightning strike and re-ip. I’m leaning toward a pfsense issue related to the re-ip and not wifi the access points since this has happened when connected to a different AP and the Harmony Hub is on an AP with an SSID that I’m not using anywhere else.

Just adding my experience. I can’t get the hub to connect to the Home Assistant anymore. I say anymore because the integration was sitting there with entity so it must have worked at some point.

My Android app and IOS app connect fine to the hub but I cannot ping the hub from my PC nor from the Home Assistant SSH. However I CAN ping the Harmony Hub from my Android phone. Maybe the hub is doing something tricky?

are your devices on separate vlans? Do you have rules in place to block communication between vlans?

1 Like

Nope nothing complicated here. Just one network 192.168.1.x

Thank you petro, the automation does it’s magic. With a little change to your post:

It has to be

- alias: Restart Harmony
  trigger:
  - platform: state
    to: unavailable

not

- alias: Restart Harmony
  trigger:
  - platform: state
    state: unavailable

:+1: :pray:

Ah yeah, thats right. Oops!

Just now HA found my harmony hub again. Haven’t changed anything today with HA except I have put a new switch in that room yesterday. Maybe that has helped some sort of discovery issue?

I was finally able to figured out the problem with mine. It wasn’t dhcp related even though it followed the dhcp lease 50% renewal time even when I changed the dhcp lease time. I had it connected to an access point for basement devices but the Harmony hub was the only device using it that I was actively using. The AP was having issues. The SSID wasn’t visible anymore but devices that were previously connected and had an IP were still working. After rebooting the AP, The SSID was visible and everything started working again. Replaced the AP and the problem has not reoccurred. Previously, every time I got to the basement, the hub was back online so I could never troubleshoot.