Harmony hub loses connection frequently

That was the solution for me! Thanks for this hint.

I had to disable wlan-steering and enable “wlan co-existency” (to force the logitech harmony to only use 20mhz). It did not work with 40Mhz.
Using Mesh-Router had not been an issue for me.

I am also having issues. My Logitech hub is online and works fine with the Logitech harmony app on my phone. But this morning it became unavailable in HA. I double checked the IP in case it had changed for some reason, but it has not (pinging also works fine). I enabled XMPP ages ago.

Does the harmony integration depend at all on the cloud, ie, does it communicate with logitech servers, or does it communicate locally directly with the hub?

xmpp does not communicate with any cloud. The other version api does.

I have 4 Harmony hubs / remotes and am seeing a lot of errors related to at least a couple of them. I am convinced it is related to Harmony’s notorious poor wifi connectivity. My networking gear is 100% Unifi and their forums have lots of posts dealing with the proper settings to cater for very flaky Harmony hubs. My 2.4GHz, and even more so, my IoT dedicated 2.4GHz SSIDs are both configured with the most basic settings to deal with Harmony and LIFX… however I still have issues.

This morning I was looking at signal strengths as received by the AP the hub was connected to and noticed it was pretty low (-68dBm). For some reason it kept connecting the one of my 4 APs that was furthest from it. The hub was also sitting on top of an AV Receiver (but no heat issues) which is a metal box so I now moved it to a side to see if it helps. I also kicked it off the wifi network until it connected to the closest AP.

I need to figure out a way to log network connectivity and signal strength with timestamps to see what happens when I get the Harmony HASS log errors. Unifi’s latest beta firmware supports locking a client to an AP so I might try that too.

While Unifi says the signal of the 4 hubs is low, I believe it is ‘OK’.


For those having issues, also look into fast roaming, band steering, and all the more advanced wifi features that apparently just cause trouble with Harmony Hubs. I turned them all off on the SSIDs that handle this gear as these features aren’t needed anyway and only cause trouble - especially on older hardware such as the Harmony. I am quite upset at Logitech for killing the product line… hopefully good alternatives step up.

You can set your UniFi APs to have individual ssids to ensure non-moving devices stick to the closestAP.

True, but it is my understanding there is a performance penalty (having lots of SSIDs) on top of the complication of not being able to easily move devices from one AP to another. With the latest beta firmware it is actually super easy to lock a wifi client to a specific AP:


EDIT: I just locked all 4 Harmony hubs to a centralized AP that receives all hubs with a relatively good signal.

EDIT2: Lol, just noticed that in one view -49dBm is green and in the other yellow… so Ubiquiti doesn’t seem to have it’s good / bad scale figured out properly.

This was the issue for me once I blocked local network access for my Hub, which was fine until I realized the WiFi kept dropping connection regularly. I was still able to access it, but the connection drops were way too much. Unrestricting that access fixed it, although I am not sure why or what I could set to allow minimal access to fix this issue. Anyone know exactly? Thanks.

Yeah not sure HA can solve these connection issues but guess we vent. I have all Ubiquiti Wi-Fi and each AP is connected to a wired connection. No mesh networks. Static IP. I never really noticed an outage before but in the logs shows failures to connect and since I’ve started automating some of my TV stuff with Alexa and Harmony noticed sometimes it doesn’t respond and logs show a timeout. Looking in HA it shows the last 5 records which I have to assume is the Harmony dropping a LOT.


I am seeing this too and if the harmony has an activity playing it goes to the home screen in the middle of playing the media.

I just started noticing this 4 days ago. Haven’t made any changes with my Unifi network as of late.

I got this a few times today. I have lots of automations for when the harmony hub activity switches, I do things that harmony can’t do (or doesn’t do well) like setting pc volume among other things.

Today when the activity went to “Unavailable” from HAs point of view, and then back to a real Activity, the automation of course fired, so it set all sorts of things haywire :slight_smile:

I wonder should we report these on the logitech site? I wonder do they correlate across hubs date/time wise or is it per home specific. I have a nest wifi router about 2 meters from the hub so I can’t see how it could have any issue with a wifi connection.

These were a few in the past hour that I spotted.

2021-11-14 22:23:25 ERROR (MainThread) [aioharmony.hubconnector_websocket] Connection timed out for hub 17762489
2021-11-14 22:34:04 ERROR (MainThread) [aioharmony.hubconnector_websocket] Connection timed out for hub 17762489

Whilst I hope we can get this sorted out properly you can help with your automations by setting a condition of NOT FROM STATE UNAVAILABLE similar to this:

  - condition: template
    value_template: '{{ trigger.from_state.state != ''unknown'' }}'

That’s fantastic, many thanks for that!I guess in my case, it went from ‘unavailable’ to the activity, so I’ll try

condition: template
value_template: '{{ trigger.from_state.state != ''unavailable'' }}'
1 Like

Good luck with that. I guarantee you that they won’t help you, they have no interest in helping you connect the remote to a third party application.

1 Like

I run HA now for a long time, never had this issue with my Harmony Hub…

1 Like

Same here, 6 years running outside the 2019 Logitech curfuffle

I have been encountering this problem quite a bit recently. All three of my Harmony hubs are dropping their connections.


I do have a recent change in my network which may correspond to the issue. I recently replaced my router with an Orbi RBK852 mesh system. @Valiceemo or anyone else with this issue, do you also happen to have the same Orbi system?

No, I dont use Orbi.
Just standard ISP provided router

That helped me! Thanks! It was so annoying when it just disconnects while using the android app.