Has anybody tried upgrading the deconz addon to 2.12.06 (addon 6.10.0)?

I just saw this on the forum:

Did the update yesterday and it’s running and operating fine for me.

Pi4 using Home Assistant 2021.8.8 (Home Assistant OS) and a Conbee II stick.

Same configuration, no problems found after the upgrade.

Just updated. No problems here.

Good to hear everyone, thanks for posting back!

I upgraded to 6.10.0 from 6.9.0, and the addon will not start. I got the following error messages:

curl: (7) Failed to connect to port 40850: Connection refused
[22:38:25] FATAL: Can't get data from deCONZ gateway
[22:38:25] INFO: Starting VNC server (local/yes)...
In exit
Closing socket listening at
22:38:22:303 DB UPDATE device_descriptors SET data = x'010401070101060000060400040005010003000200001900', timestamp = 1629599902 2021/08/21 22:38:26 [notice] 316#316: signal 15 (SIGTERM) received from 312, exiting
2021/08/21 22:38:26 [notice] 1362#1362: exiting
2021/08/21 22:38:26 [notice] 1362#1362: exit
2021/08/21 22:38:26 [notice] 316#316: signal 17 (SIGCHLD) received from 1362
2021/08/21 22:38:26 [notice] 316#316: worker process 1362 exited with code 0
2021/08/21 22:38:26 [notice] 316#316: exit
[cont-finish.d] executing container finish scripts...
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.
[s6-finish] sending all processes the KILL signal and exiting.

Does anyone have some suggestions on what to do and how to debug this? Thanks.

Uh oh, it doesn’t seem to be the same error as reported in the deconz community at the top, so it might be a place to start by posting it there?

Yeah, I’ve been fruitless trying to chase down this issue. I’ve done a bit of searches, I’ve filed an issue report in the DeConz Github project page, I’ve posted in the DeConz Discord page; and now a post in Home Assistant. Since nobody seem to have this issue, the DeConz people thinks it’s an addon problem, and the addon people think it’s a DeConz issue. Guess I’ll wait it out to see if the next update does anything.

Grr, yeah, that’s the usual ‘it’s not our problem’ and unfortunately the addon developers are not beyond that.
I wish that it would be possible to focus on the problem, and dig until you find the cause, and then you can start blaming other people.
But I guess, that’s why people go with Homey instead of Home Assistant.

I get this after update:

Failed to start add-on
409 Client Error for http+docker://localhost/v1.41/containers/create?name=addon_core_deconz: Conflict ("Conflict. The container name "/addon_core_deconz" is already in use by container "66504be3ff2f38d7dfb252407a498b87b0cf917ec236906333c2e708c0d871c2". You have to remove (or rename) that container to be able to reuse that name.")

After a fresh clean new installation + restore snapshop, update works!