Has anyone used a Unifi Cloud Key 2+ (Unifi Protect) with HAss?

Hi all,

I’ve just replaced my CloudKey and a VM running the Unifi NVR with a Cloud Key 2+. Great little device but Home Assistant won’t talk to it. My logs are full of

2019-03-26 13:18:10 ERROR (SyncWorker_8) [homeassistant.components.camera.uvc] NVR refuses to talk to me: Request failed: 404
2019-03-26 13:18:10 WARNING (MainThread) [homeassistant.components.camera] Platform uvc not ready yet. Retrying in 180 seconds.

I haven’t investigated this yet. I assume it’s a 404 error because the CK2+ doesn’t serve up some page in the same location as the NVR VM did. Therefore this will require a change to the code of the uvr module. However, I thought I’d ask in here in case anyone else has seen this before I start submitting bug tickets.



Bumping this…

Can’t find a username for the cameras and Unifi Protect local user creds don’t work. Neither does the Settings > General > Device Password with any username I could think up.

I’ve tried both the generic and uvc camera platforms. The uvc component’s docs don’t match up with what’s in the cloud ket gen 2 + interface–there’s no user assigned to an api key…

Anybody have this working–either for streams or stills or both?


Just found this thread and it got me connected.

I was able to get logged into the camera’s IP with http (no “s”) and see camera settings. No SSH required.

Note that I did have to check the box to “Enable Anonymous Snapshot”. I could not get any combination of username/password to work. The unifi_protect_device_password is in Protect > Settings > General.

Camera login:

    username: ubnt
    password: unifi_protect_device_password

Here’s my config:

  - platform: generic
    name: Camera1
    still_image_url: http://camera_ip_addr/snap.jpeg
    stream_source: rtsp:///string_from_protect_settings_for_the_camera

And Lovelace cards… The still image version streams in the pop-up window after clicking the still.

entity: camera.camera1
type: picture-entity
name: Camera1 Still

entity: camera.camera1
type: picture-entity
name: Camera1 Live Stream
camera_view: live

type: picture-glance
entities: []
camera_image: camera.camera1

I saw this in HACS and finally got around to installing it today. It worked from the start with my Cloud Key Gen 2 Plus and has motion, camera and device tracker support. Nice!

Many kudos to @briis! :clap:


Big agreement here! @briis has been crushing it between this and his Smartweather plugins.

1 Like