Has it updated or what?

I installed HA on a Raspberry Pi3+ in the beginning of this year.
I did not have the time to work with it, So it just run.

Yesterday I bought two telldus net v2 an thought that I should test them, but I can’t access the web interface. I have rebooted the pi, I have restarted the docker image.

I don’t remember much of docker and about HA config files…

Has there been an automatic update or what have happend?

Ideas anyone?


It doesn’t automatically update unless you had something that you programmed to do so.

Just reinstall and start over.

There are several changes and updates since beginning of year and sound like you never use anyway. It will take you forever to troubleshoot this and 15 minute or less to reinstall.

And NO. It did not auto update. Likely your SD card ran out of storage or failed.

1 Like

Ok, thanks!

Hmm, were is the howto I used…

If you don’t install according to the official documentation, it is worthless.

1 Like

I don’t know if it was official, but it worked.
Without any “magic” things that you just should know about…

well, if it was current with the official documentation, then it would have worked. Home Assistant changes so quickly, that following a guide from 6 months ago could leave you with a mess of an install.

Just use the official documentation.

I think the point @flamingm0e was making was that the install instructions link is on the HA website literally at top of page… “Getting Started”

Anyway, for raspberry pi just flash the correct image from site below, install in Pi, turn on pi and wait about 15 minutes before connect to http://yourPi_IP:8123

if using wifi I think it tells steps for setting this up.

Well, I can not just load a new image on it. There are a bunch of otjer small services running on the pi…

Docker is installed and I need it from there.

Technically, if docker that’s exactly what you should do.
Get latest image from docker hub and run it…those instructions can be found here

Thank you!

Right now i am trying to remove the old hassio from docker, but it allways restarts. I will retry tomorrow, using my computer instead of connectBot on my cellular…

Possibly it ran out of space or your home-assistant_v2.db file is corrupt.
That’s what happened on my pi3.
I did the same thing… got it working with a few integrations, and happily used it for a few months until it blew up. It turn out home assistant by default will keep saving events and analytics into this db file and never clean it up. Pretty scary. It grew to 3+ gigs and corrupted my whole pi install.

I have since learned about the “recorder” config variable, set it to 7 days and now this db file stays around 75 megs.
If you can ssh to it, check that file.

Oh, yes, that could be a problem…

Well, I started to remove a lot of containers and images in docker.
Only two left, hassio_dns and hassio_supervisor.

This will probably be a mission for the evening, together with some beer and snacks!

Oh, the home-assistant_v2.db file is 729 MB…

What was that setting?

Well, reinstalled container and they (?) starts,
homeassistant, hassio_dns and hassio_supervisor.

Stopping and then starting docker and no container is running.
So now it was possible to remove all images!
And reinstall, again.

Got something up and running! :o)
But, in the old one there was something called hassio (could be wrong ?!) where I could add things like tellstick net mqtt etc.

Later it will be a clean installation on a new Pi for my summer house…

Sounds like you didn’t follow the directions very well.

Ther is not much to follow https://www.home-assistant.io/docs/installation/docker/

The configuration.yaml is allmost clean!

That’s not for hassio. That’s for normal home assistant. You were linked the instructions for hassio. The problem is that you were using hassio which creates a service. Unless you remove the service, when you reboot, there will be conflicts.