HASS agent geeft geen entity_id!

Hello everyone,

I have a problem with HASS agent. I have now completely removed this from every PC at least 5 times (including the files in %app data% and program files) and completely removed it from HA and reinstalled it. But still I don’t get media_player entity!!
I tried it at 4 pc. It seems to me that all connections are OK (see image).

Does anyone know where I should look to find out what’s wrong?

Thanks in advance for any response.

I was JUST running this myself for the first time…did you add and activate sensors?

I added only the battery for now and then it presents this


Yeah, last HA update broke this. Check solution here (near bottom of page - a temporary solution is written - requires editing of one file):

Bug: Latest HA Core update 2024.5.0 breaks notification entities. · Issue #75 · hass-agent/HASS.Agent (github.com)

Thank you for your response. I can do this too, but I don’t see an entity for a ‘media player’, that is precisely my problem. But apparently it is due to the latest update from HA!

Thank you for your response. Will try these adjustments and let you know if it worked!!!

Sorry, but I tried the solution but nothing changed for me!!

I think I misunderstood your question then… you want to SELECT a media player into the agent? That works for me 2024.5.2

If not the question then sorry but it is unclear as just a new user to this tool so not aware of any missing func.

Thank you for your reaction.
No, that was not my question.

Normally when HASS is installed a media player entity will appear from your PC and this no longer happens. Apparently this has something to do with an update of hA. There is a solution above but this doesn’t work for me either!!

OK thanks… I understand that the PC is shown as a media_player in HA …that would indeed be nice