HASS.Agent: Windows client to receive notifications, use commands, sensors, quick actions and more!

Thanks a lot for your help, the camera object trick worked :smiley:

Yep updating the integration has fixed it, pictures are coming through again. Thanks!

I did it, my bad

After today’s update both media players work ,so my problem (described above) is solved.
I guess that now i can remove media player addon and keep only hass integration, correct?

Is it normal that the media player shows no cover art when added to the default HomeAssistant media controls card? I thought that the Windows Media API provides the image matching the current playing media as well. I’ve tested Spotify and Tidal which both show the cover art in the Windows Media controls.

I wonder…is it possible to create a sensor which would show when Hass Agent is to be updated? My HA runs fullscreen (kiosk mode) so just by looking to screen i don’t see if it’s update or not.
Anything - either a sensor or notification would be nice. I did some searching but didn’t find anything on this topic…

I have tested the problem with the umlauts again with the new version. Therefore, nothing has been changed yet, right?
I had posted the example text above, if you want to have a look at it. Thanks!

Great! Yep, you’re correct :slight_smile:

1 Like

No not normal, but you need the new integration for cover art to work. After installation, this integration will create a new media_player and notify entity for your PC, so you need to target that new entity for your media controls card.

1 Like

Yea of course, it’s already on my todo list: hassagent-86. Should be in the next version :slight_smile:

1 Like

You’re right @steff, but I didn’t forget - the next version will be focussed on tweaks and fixes like that one.

1 Like

oh no… I got confused with all the different integrations (I had HASS.Agent Notifier and HASS.Agent MediaPlayer installed and thought that they were enough)… Thanks :blush:

Relatable :grin: From now on, it’s just that one

I might have found a bug with the ProcessActive sensor. I have a process that I want to monitor which has full stops in the name. When I click store and activate, part of the process name is always removed. For example first.second.third gets stored as first.

Trying to get this setup, but the agent keeps closing on my windows 10 computer. Tried uninstalling it and the .net and try reinstall and same thing.

Posted on the github also as it looks like this happened to a few people this year.

Nice find, I’ll look into it [hassagent-159]

Responded in the github ticket

1 Like

I just discovered this today. The new integration, app and MQTT auto-discover all worked as expected on my first PC. However when installing on a second PC whilst the app on the PC says it is all connected, and the sensors I added show up in MQTT the actual integration hasn’t auto-discovered the second PC. I tried with a 3rd PC but that won’t auto-discover either. I tried restarting various things including home assistant but no luck. Do you have any suggestions? Cheers

Is there anything showing up in Home Assistant’s logs?

Nothing I can see
I have now got it working on 3 PCs - I just had to wait and reboot a few times. However 1 PC stubbornly refuses to show up. It shows up in MQTT but doesn’t autodetect. I uninstalled the app, deleted the folders in program files and in appdata and rebooted. then i removed the MQTT device and rebooted HA. Then started again from scratch. But that one PC still won’t autodetect - and it still remembered some settings when I reinstalled so I clearly didn’t get rid of it completely. Can you advise what paths and registry entries etc are used for storing anything related to the app so I can completely remove and start again