Hass AIO installer default http password? [Solved]


What is the default login password for a standard “Raspberry Pi All-In-One Installer” install?

I have tried he password that is listed in the “secret.yaml” “http_password: welcome”. And a few other seemingly obvious passwords,( hass, blank, haio.) However I can not log in to my Rpi’s default Hass web page, after the install.

Which browser are you using?

I have tried with Chrome and Firefox. On Win 10.

It was on a fresh 2017-09-07-raspbian-stretch-lite install. if it helps the helpers.
Edit: On a Rpi B, Old pin style.

Are you trying to access HA or the operating system?

I’m trying to access HA main web page from another machine.

I can log in to shh.

I tried twice with a fresh install of the OS and HASS AIO to no avail, Six plus hour installs. . . /sigh

Now I installed a 2017-07-05-raspbian-jessie-lite image and in the process of the install of the AIO. I’ll report back in five or 6 hours. =)

Look in your configuration.yaml for the entry api_password

Thats the strange thing. the configuration.yaml entry was all commented out:

  # Uncomment this to add a password (recommended!)
  # api_password: PASSWORD
  # Uncomment this if you are using SSL or running in Docker etc
  # base_url: example.duckdns.org:8123

In that case uncomment the line and change PASSWORD to the password you want.

I assume you’re trying to access within the same network, right??

Don’t forget to reboot the system after the change.

I did try that as well. It did not work.

Anyway I’m in the process of the AIO install on a Jessie image. It’s going to take so time to complete.

Hopefully, it’s just a Stretch thing, And I have no troubles on a Jessie image. < Fingers crossed.>

Oh farts,
A fresh install on a 2017-07-05-raspbian-jessie-lite image and it still asks for a password when login in to http://My-pi-ip.:8123

Setting a password in configure.yaml and secrets.yaml has no effect. Still cant log in.

Well I’ll guess I’ll have to try a different install method

I found my problem.

It was my proxy server messing with the connection. Configuring a browser and or a whole system to bypass the proxy for Hass’s ip address work’s

1 Like