HASS Broken after Upgrade

Upgraded to 0.45.1 yesterday, and now HASS wont startup.

No changes in log, last log entry is prior to upgrade.

Same here.
I had to remove Owntracks and all automation from my config to get the frontend to show.
With no automation hass starts after 10 seconds, with automation it takes almost 30 minutes! to start.
The only pointers in the log, are 2 entries: it takes more than 10 seconds to start automation and it takes more than 10 seconds to start device_tracker.
If someone has the magical answer, please!

I also had to go back to 0.44.1 since all of my automations broke and my main purpose of HA is using automations. Hopefully it gets fixed for 0.46 or I’ll be stuck at an old version for awhile.

same here. no reaction in log

Where you all using this before the upgrade?

automation: !include automations.yaml

v0.45 uses this by default and in order to use the automation configurator in the frontend, every automation must have an ID. Since this was not the case in earlier builds, this might be the reason they are not loading.

P.S. I did not upgrade yet because of this. Still have to add ID’s first for all my automations but the weather is way to nice to stay inside :slight_smile: .

Presuming you are happy with all your existing automations, and don’t intend to edit them using the editor, you could always change the name of the file and label the old automations:

automation old: !include automations_old.yaml

Should be the minimum amount of stress, then just add any new automations with the new format:

automation: !include automations.yaml
automation old: !include automations_old.yaml

I have not tried the new editor yet, but can confirm that all my old automations are working fine on 0.45.1 with no edits whatsoever, I just added the ‘old’ label so I’m ready to go with the editor for new ones when I get a chance. (My config was using an include_dir_merge_list for a directory called ‘automation’ (no S) ).

Hope this helps.


Will do that, thanks!

I upgraded to 045.1, innocent of the automation changes, they all continued to work. I was lucky because my automations file was automation.yaml without the s.
I tried to create a new automation using the new tool and all the triggers I selected were unsupported, including time , homeassistant !
I read some of the documentation and did not like the warning about all my comments removed in a migration.
This is a show stopper for me as I find that my comments are essential to remind me of that the automation was for. Maybe a comment field can be added to the new editor.
Other than pulldown menus for triggers and actions (that do not work) what is the point of this editor? As long a the documentation is well maintained, I happy with a text editor like NotePad++ where I can add comments, cut and paste, highlight code etc…
Maybe someone can release a Automation Editor Demo to show it off. I don’t get it now.

Thanks for this. I guess I totally missed reading that part when I upgraded. I was focused on getting letsencrypt working so it was an oversight for sure.

So if I wanted to add more manual automations myself, could I add to the automations_old.yaml or is it whatever is in there is kinda locked up and need to use the editor for new ones??

You can still add automations the old fashioned way to the automations_old.yaml. :slight_smile:

The only thing that has changed is that the new automation builder uses a file called automations.yaml that needs id tags so it can edit and keep track of them. If you previously had your automations in a file called automations.yaml then this causes a problem as they don’t have id tags. Changing the name of the file (and the include link in configuration.yaml) resolves the problem :thumbsup: