HASS can't find my external components anymore (after Router reset)

Hey guys,

yesterday I had a random problem with my internet connection and the only way I could fix it was to unplug and replug the router (power reset). The internet worked again but it seems like Home Assistant is having trouble now to find my: Hue Bridge, Harmony Hub and Spotify player.

The confusing part is, first HASS found some of them again and they worked, but because not everything was there, I gave HASS a restart and now nothing can be found anymore (also tried hard resetting it by pulling the power cable).

My Alexa system works fine and has no problems speaking to my Hue Bridge and Harmony Hub after the reset.

My wild guess is that my router changed internal IPs.
However, HASS has a static IP, so it should at least find Spotify again. This is weird.

Any ideas what I can do? The “discovery:” command is active in my configuration so I am even more confused why it doesn’t find anything anymore.

Ok this makes me feel really dumb. This thing didn’t work all night and I did several restarts, then went to sleep just to see today that still nothing worked (so I did this topic). Just right now, I did one more restart in HASS and everything popped up again. What on earth happened.

So, this topic is kind of “resolved” but it still let me question why it had problems in the beginning.

Same poblem by me with Philips Hue and Cameras…