HASS HADashboard

I am having difficulties getting HADashboard live. I have Appdaemon up and running without issue. I have the following as the first lines in my configuration.yaml :slight_smile:

dash_url: http://XXX.XXX.XX.X:8124
dash_dir: /home/homeassistant/appdaemon/conf/dashboards

But when I load Hass i get the following error:

2017-07-07 13:16:56 ERROR (MainThread) [homeassistant.loader] Unable to find component HADashboard
2017-07-07 13:16:56 ERROR (MainThread) [homeassistant.setup] Setup failed for HADashboard: Component not found.

I am a newbie and trying to convert from Smartthings. Any help would be greatly appreciated.

hey there,

try: dash_url: http://XXX.XXX.XX.X:8123

Edit: Man, I am a dummy. I guess it was too early to reply. See below for other correct answers.

did you really setup the dashboard to be on port 8124 instead of the default which I think is 5050? what do you have for your app_dir? Or really, can you post the whole config?


Name of the location where Home Assistant is running

name: Home

Location required to calculate the time the sun rises and sets

latitude: 42.9057
longitude: -78.6264

Impacts weather/sunrise data (altitude above sea level in meters)

elevation: 0

metric for Metric, imperial for Imperial

unit_system: imperial

Pick yours from here: http://en.wikipedia.org/wiki/List_of_tz_database_time_zones

time_zone: America/New_York

dash_url: http://XXX.XXX.XX.X:5050
dash_dir: /home/homeassistant/appdaemon/conf/dashboards

Show links to resources in log and frontend


Enables the frontend


Enables configuration UI



Uncomment this to add a password (recommended!)

api_password: PASSWORD

Uncomment this if you are using SSL or running in Docker etc

base_url: example.duckdns.org:8123

Checks for available updates

Note: This component will send some information about your system to

the developers to assist with development of Home Assistant.

For more information, please see:



Optional, allows Home Assistant developers to focus on popular components.

include_used_components: true

Discover some devices automatically


Allows you to issue voice commands from the frontend in enabled browsers


Enables support for tracking state changes over time.


View all events in a logbook


Track the sun


Weather Prediction

platform: yr

client_id: 27c356f1-29b4-458a-9fb4-3829a75837d2
client_secret: 3NpJkG6wcVeUehHz8D0BUE9ak


  • platform: spotify
    client_id: 80b4b8b4dad943bd93d9441bd65c5bbb
    client_secret: ddcb88dda47144ec849bd020bc41a9c7

Play random playlist and switch to Amazon Echo

alias: ‘Spotify at Pool’
- service: media_player.select_source
entity_id: media_player.spotify
source: Rock
- service: media_player.play_media
entity_id: media_player.spotify
media_content_type: playlist
media_content_id: >
{%- set plists = [“spotify:user:spotify:playlist:37i9dQZF1DX5mB2C8gBeUM”,
] -%}
{% set pindex = (range(0, (plists | length - 1 ) )|random) -%}
{{ plists[pindex] }}

group: !include groups.yaml
automation: !include automations.yaml

So, you put part of the HaDashboard config in your homeassistant config. That’s is not how it works. There is a separate config file in /config/hadashboard/ where you need to point HaDashboard to your HA entity.

It has all the needed information in it but you need to edit it. For example, add your HA password.
Also, are you using the resin.os image? Your dash url looks like you are using Raspbian or some other linux distro.

I apologize. I am using the Hassbian image. I do not know where the /conf/hadashboard is located. Is this within appdaemon? I have adjusted the appdaemon.yaml file in /appdaemon/conf and that appears to be working. I am just struggling with the hadashboard side.

Thank you, your guidance got me pointed in the right direction and I am live

1 Like

Hi SunMoonStars,

I’m trying to get the dashboard up and running and I’ve done the same mistake as mikulec.

I believe the documentation (http://appdaemon.readthedocs.io/en/latest/DASHBOARD_INSTALL.html#installation-and-configuration) is confusing as it doesn’t mention to create the file under /config/dashboards/

I’m running hass.io and I did install the AppDaemon, then I’ve created the /config/appdaemon.yaml, though not sure what are the below entries:
cert_path: is it the /ssl/fullchain.pem, I use to https to HA?
api_key: is it the https password for HA?
api_ssl_certificate: again not sure what this one is?
api_ssl_key: is it the /ssl/privkey.pem?

After your comment I took the below line from /config/configuration.yaml and created /config/dashboards/config.yaml adding the line to it:


One question though, is the above ip address for the HA, or is it for the device displaying the dashboard? And for test purposes can we run the dashboard from a laptop before we move it to a tablet?

I did restart the AppDaemon add-in as per documentation but I’m still not being able to get the dashboard running! I did read few posts on the Forum, but most of them assume you passed this basic point.

I really do appreciate your input on how to get the hello.dash (as per documentation) up and running.