HASS/HASSOS on an old 32-bit laptop?

I have an old Asus 1000HE laptop which has a 32-bit processor. I want to dedicate this machine to Home Assistant so I’m thinking I don’t need to install Docker on it.
Could you kindly tell me:

  1. Can Home Assistant Supervisor or HASS OS run on a 32-bit machine?
  2. What is the recommended install for a dedicated computer?
    Thanks in advance!

i hope, this still is valid…

1 Like

Thanks so much for your reply! I’ll try it out.

It appears that one of the links in this guide is bad, i.e.
wget https://github.com/home-assistant/os-agent/releases/download/1.2.2/os-agent_1.2.2_linux_i386.deb
dpkg -i os-agent_1.2.2_linux_i386.deb

I think the correct link is:
wget Release 1.2.2 · home-assistant/os-agent · GitHub
dpkg -i os-agent_1.2.2_linux_i386.deb

Thanks! this appears to work. I got Home Assistant Supervised running on a 32-bit old laptop, the 1000HE Eee PC.

1 Like

When Home Assistant first came out, I ran the core on a 32bit machine no problem. But whenever I needed to run Docker containers, I found some were built for 64bit systems (example amd64) and these won’t run on a 32bit system. So you may be fine, but be aware of this limitation.

Hi there
Just registered to inform that I just successfully installed Home Assistant on old x32 laptop (Some Intel Atom and Linux Mint) from container.
Do not even ask how I did install Docker)))
I tried build some old x32 docker, used some repos.
Finally in is - Docker version 20.10.7, build 20.10.7-0ubuntu5~18.04.3. It is i386

So I just installed HA from Docker and it working.

You save my life. thanks a lot…

1 Like

No, I did not. Ntguest on GitHub did :wink:

Hi, I have a similar PC, I was able to get everything I think I need to run HA Supervised except docker-ce. How were you able to do that?

Hi all.

I’ve been able to get the latest version of HA supervised running on a Sony Vaio P (who remembers those), which is shaping up to be a great little low power HA server which is small, has built in WiFi, built in screen ect for admin and looks great sitting in my entertainment unit. I am sure any of the other late 00’s and 10’s cheap netbooks people have lying around would be just as good.

What I had to do was recompile the supervised installer to accept docker.io as a dependency.


  1. Setup the system with Debian 12, ticking yes to linking the backported software repositories

  2. Follow the instructions for installing HA here: https://community.home-assistant.io/t/installing-home-assistant-supervised-using-debian-12/200253?u=homearesistant
    a) Dont run the line curl -fsSL get.docker.com | sh, which installs docker-ce, instead install docker.io which is included in the standard debian repositories for i386: sudo apt-get install docker.io
    b) Use the 32 bit version of os agent: os-agent_1.6.0_linux_i386.deb
    c) Grab the source code for the home assistant supervised installer and modify it to support docker.io
    i) Change the line in /homeassistant-supervised/DEBIAN/control from:
    Depends: curl, bash, docker-ce, dbus, network-manager, apparmor, jq, systemd, ...
    Depends: curl, bash, docker-ce | docker.io, dbus, network-manager, apparmor, jq, systemd, ...
    ii) Compile to .deb (using the command found in .vscode/tasks.json) chmod 555 homeassistant-supervised/DEBIAN/p* && dpkg-deb --build --root-owner-group homeassistant-supervised
    d) Use the new homeassistant-supervised.deb you just created instead of the released .deb

This got me a fully functional x86 install of HA supervised that is happily supporting my MQTT devices and runing the website with good speed. Theres a chance some docker containers won’t work, but this has not been a concern for me.

Lets keep these little power efficient x86 pcs out of e-waste :slight_smile:


1 Like