Hass.io - Add Support for bluetooth on Intel NUC devices

it would be nice to be able to use bluetooh on NUC devices and not just RPis. Who is with me?

Isn’t it interesting that more poeple find more usefull support for Tesla Motors API and Car Net VW than bluetooth on NUCs? LOL

1 Like

If you are running Hass.io on a nuc, but in docker, you can use bluetooth. Just “apt-get install bluetooth” on the ssh in the nuc and “hcitool scan” to see that it’s working. I had to run “sudo hciconfig hci0 up” too to get it up and running, but now it’s working fine.

1 Like

this doesn’t work

I use Hassio on Intel NUC, and when type apt-get install bluetooth I get error:
Any help?

the goal is to use MiFlora on Home Assistant


Are you using hass.io whole os?

resinos + hassio
afaik, there is no hassos distro for intel NUC.
or am I wrong?

Not HassOS, no. I’m running HassIO in Docker on my NUC via this: https://github.com/home-assistant/hassio-build/blob/master/install/README.md

What type of Linux system are you running this on? Considering to move away from rpi3 and have an old NUC but no experience in Linux.

Are you asking me? In running Ubuntu server. I also have no previous experience with Linux.

Did you guys get this working?
I too am looking to integrate mi flora on my system, which is hassio on ubuntu (on ESXi, but that is unimportant other than the BLE USB device needs to be passed through).
Is there a specific model or chipset for BLE dongle I should seek out?

Anyone got this working on a NUC with Hassio (No Docker - jus the NUC Image)?

Bluetooth is broken at the moment - there’s an issue about it on github, but it’s not getting much attention.

Okay and thanks.
Would have been easier if they just used zigbee like they do on many of their other products :).

Same problem here. Running Hassos image in Oracle VM and no bluetooth, everything else is working great !

Tried both internal bluetooth and separate bluetooth usb dongle, but no bluetooth in HA.

Maybe anyone have a solution/workaround?

Works again with 105.2 and new hassos/ovi-image
Thanks a lot for fixing this !

Anyone having any joy with esxi on a nuc using the vmdk? Do I need to reinstall with a new version of it for bluetooth as it’s currently not working. I’ve tried various dongles passed through to it…

Did any one on hassos ever got usb running?

If you are running Home Assistant (aka hassio) on a generic linux dist remember bt need to be fixed first as it wont work out of the box (also make sure bt is enabled in bios). Then you have to setup iwlwifi as bt is not supported out of the box.

After I did that bt worked with no issues in the home assistant (hassio)

I’m running the Home Assistant NUC image updated to Core 0.110.3 and HassOS 4.8, running on an older i5 NUC without Bluetooth. I’ve added Trendnet BT 4 USB dongle and it no-go for me. lsusb on console shows:

Bus 003 Device 002: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

This shows that the BT dongle is detected, just nothing using it. Doing some further searching, I does seem that bluetoothctl, bluez-simple-agend, and blescan, so at least some of the bluetooth utilities are installed, but it does not appear that bluetooth service itself is running… so lets find that first…

The NUC HA image is missing many of commands in the terminal that you would normally expect (busybox?), and systemctl is one of the missing ones. I located the bluetoothd daemon in /usr/lib/bluetooth, I tried running it manually but here is where I think the problems lie:

bash-5.0# ./bluetoothd
D-Bus setup failed: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory

A quick search of the filesystem and the “system_bus_socket” dbus directory/file does not exist. In fact, the entire /var/run/dbus is empty… There is another directory, /run/dbus, but this is also empty.

At this point I’m stuck. I could dive further into this but I think the real answer is to just build a HA system on my NUC from scratch, starting with Ubuntu… I’d like to see this fixes but I don’t see that happening anytime soon…

1 Like

Good job … I also installed Hassos on Intel nuc, and Bluetooth is detected by the esxi machine (intel product 0x0a2b) but inside Home Assistant it doesn’t work … Hopefully someone will solve the problem …

1 Like