Hass.io and Alexa

hassio
alexa
Tags: #<Tag:0x00007f4801776690> #<Tag:0x00007f4801776140>

#1

Hi,

I was running HASS on Pi2 running Hassbian and had configured my lights / switches with Emulated hue to make them operable with Alexa.
No cloud service in play, all local on LAN and everything was working fine.

Decided to upgrade to HassOS running Hassio on Pi3 B+
configured the system, copied my configurations and as far as I know everything is working fine in Home Assistant with the exception of Alexa unable to discover my devices.
On Alexa App, Device is unresponsive is displayed on previously discovered devices, and a new discovery scan does not find anything.

The most relevant changes that I can think of are:
1- IP address change
2- Running Hassio

I looked at few related discussions here and here

Tried all the suggestions in vein
If I power up my older pi2, Alexa starts working again.
Needless to say, the new configuration for emulated_hue has the new ip value and is not pointing to the older device.

I’m at witt’s end and can’t figure out what to do next to get it working again.
Would changing the new device IP to the older device’s value fix the issue or is this a Hassio / docker limitation / mis-configuration?

Thanks
BB


#2

I forgot to mention that
http://<HA IP Address>:8300/api/pi/lights returns a list of devices.

Thanks
BB


#3

Have you tried deleting all your old devices before rediscovering? You actually have to do it via the amazon alexa website and NOT via the app.


#4

Thanks @EGO01

I just tried deleting one device via Alexa website, then scanned on the app and on the website and even tried to add a device manually, nothing was found.
I’m apprehensive about deleting all my devices, I have quite few routines setup and I don’t want to lose all of that.
If I know for sure it will work I might dare.
Do you know for a fact that it’s what I need to do? or is it an educated guess?

Thanks
BB


#5

Sorry no promises it would work. It is an educated guess.

Any reason why you haven’t given you’re new pi the same IP address as you’re old one?


#6

I have to restart Hassio then as soon as its back up discover devices with Alexa…


#7

@Shayne_Bergan that trick didn’t help :frowning:
@EGO01 because I have other services running on that device that are used by various systems, it can be done, but it’s a PITA.
If I know for sure that, the IP is the issue, I will go through the pain.

Thanks
BB


#8

Update

For anyone encountering similar issue
Update of Hassio to 0.83.3 fixed the issue.
Although at first Alexa detected all my devices, asking here to turn off the kitchen lights made he turn of the basement light, or something else.
I had this issue will all the devices, the commands wouldn’t go to the correct device.
Removing all devices from Alexa and scanning again fixed that issue.

So it had nothing to do with IP.

BB