Hass.io and Bluetooth

Is anyone having an issue with HASS.IO and BT where the BT on the RPI seems to be sleeping at some point and showing all devices as away? After a fresh power cycle (restart does not help) the BT works fine on all devices, showing home and away as it should but after some time (haven’t determined exactly but several hours) it seems the RPI must be dropping BT or BT sleeps as all devices show away at the same time and never show home again until I power cycle the RPI, is this a settings issue in the BT Addon?

I’ve moved this to it’s own topic as the (old) thread you hijacked was about Hassbian. Please don’t hijack threads :wink:

I believe other people who have reported this were running their Pi3 on wi-fi. If you can, you might try switching to Ethernet.

Sorry about that hijack, thanks

I have been running wired from the beginning so it can’t be the wifi issue. Do I need anything other than the basic config I have setup below? The asus tracking has been great, just the bluetooth drop off problem, do I need a separate interval for bluetooth?


  • platform: asuswrt
    host: IPxxx
    username: userxxx
    password: passxxx
    interval_seconds: 5
    consider_home: 90
    track_new_devices: yes
  • platform: bluetooth_tracker

This is what I have in my configuration.yaml.

  - platform: bluetooth_tracker
    interval_seconds: 15
    consider_home: 150
    track_new_devices: yes

I’ll add the interval and home lines and see if that helps. Thanks. Do you have any issue with battery drain on your devices with the bluetooth tracking or since it is just looking for a bluetooth ping maybe there should not be any extra load on the iphone?

No. Bluetooth presence detection on our iPhones has been flawless.
Best example - My Christmas tree lights up as I pull up to the garage. No impact on my battery.

So I thought adding the interval was going to fix it as it worked for the rest of the day and all night, but it just cut out again this morning. It must be on the RPI side as all devices show away at the same time. I don’t see anything in the logs for the bluetooth tracker which is odd, is there a way to turn on logging so I can try to see what is happening? Even the Bluetooth Add On log section is always empty? I am also going to try to uninstall the addon and reinstall to see if that makes any difference.

Do you have an appropriate sized power supply on the pi?

I think so, it is a 2.5amp PS so that should be good correct?

Yeah. That should be good

Still odd I can’t see anything in the logs for Bluetooth.

So I can see the basic Bluetooth add on startup logs when I do a power cycle showing that it was successfully running. However, when the Bluetooth cuts out, as it did again, if I try to restart the the Bluetooth add-on I get this in the log:
starting version 3.2.4
Initialization timed out.

So it really seems the Bluetooth radio is sleeping or stopping and only a power cycle starts it again. Can’t figure what to do next.

Update, I had been running the FFMPEG component which was super buggy and threw off many errors as it does for many people. I recently moved to the Xeoma platform which has been great and ever since then my bluetooth has been worked correctly, so perhaps there was something with the FFMPEG errors causing the RPI to shut down the bluetooth after some time, it’s odd but working now.

Not to revive, but to add.
I was having the same bluetooth issue I am also using FFMPEG and stumbled here

Now on 0.65.6

I tried updating to 1.3
Latest version 1.3
Type resinos (GNU/Linux)

After a successful reboot and upgrade the bluetooth
add-on is working

Set Controller UART speed to 921600 bit/s
Device setup complete

Thanks for the add. Just curious, how did you set (or check) the UART speed? Wondering what mine is at.

Sorry I have no clue.

I added Bluetooth the. Upgraded.
No other setting were altered.

That excerpt is from the logs.

Thanks, I do see that in the logs.

I noticed that at least one paired Bluetooth device is required in the “My Devices” list for Bluetooth tracking to work well on an iPhone. It seems that the iPhone turns off bluetooth even though it is turned on if the “My Devices” list is empty.