"Hass-io" blank window after upgrading to 0.75


I see a blank page when I click on the Hass.io tab. I’ve read tons of other threads related to this issue in other versions, but none of the proposed fixes work for me.

What I tried:

  • Incognito window on Chrome
  • Clearing cache
  • Fresh Firefox install
  • Tested other browsers: Safari, Chrome regular/Incognito on Android
  • Rebooted Pi and Hassio several times

There’s no related errors showing up in the log. Any suggestions?


I’m having the same problem. For unknown reason my late 0.72.0 has crashed and my homeassistant
was unreachable via web or SSH. Apparently samba and mosquitto were not working either, so i decided to reinstall hass.io from scratch which installed 0.75.0.
Now the hassio page is always blank no matter what I try so homeassistant and my system is completely useless. Since I can’t install any addon like HASS Configurator, SMB or SSH and i can’t load or edit my configuration.yaml in any way.
Please help!

Edit: After reading the blog I reinstalled again that updated to 0.75.1 which supposedly had a fix for cutom panel and hassio panel. However this changed nothing… still the same issue.

Edit 2: Finally resolved (for now) afret reboot via dev-service -> hassio.host_reboot

1 Like

Hi. I had the same issue during 0.74 > 0.75 > 0.75.1 migrate.

On 0.75 i went to SSH and connect to my root@ipaddress port 22 (with public/private key),

then I use hassio ha update -o version=0.75.1

And after install i had the same white screen. Tried to reboot my Pi couple of times + always clear firefox cache and after 2 attempts everything started to work fine. Maybe this will be a better method for someone than reflash SD card and run clean copy of HA again…

Same issue except I’m using chrome. Tried all the suggested fixes but still no go and I think alot of them had to do with other browsers like firefox, IE, etc… I had it working before but had to do a clean install and now I can’t get the Hass.io to come up. Tried older version and the most current with no success.

Yep…same issue here.
I am running 0.74.2 in an Ubuntu 16.04 VM (Docker install), no issue.
I was thinking of testing HASS in Ubuntu 18.04 (I like the idea of a recent OS!), and 0.75 installed. Blank Hass.io screen… Reading this thread again I started it all from fresh, and installed 0.75.1, same issue.

I do see this in Chrome’s dev tool:
Failed to load resource: the server responded with a status of 404 (Not Found)

Which I do not see in 0.74.2.

So I guess for now Ubuntu 16.04/HASS 0.74.2 will remain!

worked for me. Thanks

I don’t know if this actually did anything… But while searching for a solution, I saw something about rebooting with SSH and did the generating key with putty. I added the files to the SD card, hoping to access through Putty. On a whim, I loaded the HA just to see and Hass.io page loads!

So far, I tried getting this to work with 3 different SD cards (just to make sure it wasn’t a bad SD card which it wasn’t…) and they all work now. Below is the link/instructions I used. (Ironically, I still couldn’t access through Putty… LOL)


To acces through putty on port 22222 you must create authorized_keys with public key inside and save this to your root directory insideUsome USB stick named CONFIG then in hassio panel you must click Import from USB.

Check out this github issue for a resolution: https://github.com/home-assistant/home-assistant/issues/15816

TL;DR update to 0.75.1 - e.g. by rebooting your raspberry

I have the same problem with white screen on hass.io meny and are on 0.75.1.
Is it possible to revert back to 0.74?
Or is it perhaps better to wait for 0.75.2 and hope for the best?

  • Called service hassio.host_reboot
  • Can’t access Hassio via SSH. I removed the addon right before upgrading to 0.75. However, when I try to access Hassio I get the “permission denied” message. I didn’t set up a public key file :frowning:

So according to this, a fresh install is needed for those who can’t update via SSH, like me:

I’m going to test it and report back.

I can’t get this to work in 0.75.1. Keep getting the following error in the log:

ERROR (MainThread) [homeassistant.setup] Error during setup of component hassio
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/homeassistant/setup.py", line 145, in _async_setup_component
    hass, processed_config)
  File "/usr/local/lib/python3.6/site-packages/homeassistant/components/hassio/__init__.py", line 180, in async_setup
    refresh_token = list(user.refresh_tokens.values())[0]
AttributeError: 'NoneType' object has no attribute 'refresh_tokens'

Tried rebooting the Pi multiple times, even turned the power off/ on.

I flashed the newest image and it’s working now, on 0.75.1. As pointed out before, I had to rebooted a second time. Thanks

I’ve just installed a new hassio on 75.1 all working fine I restarted the service now it’s sitting there saying connecting grr

Which service did you restart. As mentioned before you have to reboot the host via dev-service -> hassio.host_reboot… If this didn’t work for you maybe there is something else that went wrong.

I’m rebooting the entire pi wouldn’t that do it?

I hope you are rebooting it the way I mentioned in my previous post and not by power cycling which may cause damage to the SD card and the files on it. If you did that, try flashing the hassos image one more time with Etcher following the entire procedure and try again. Be patient throughout the process - it takes time.

1 Like

i re flashed installed ssh and when i ask it to restart i get this message

panic: interface conversion: interface is nil, not string

i restarted supervisor still no go

I’m confused how did you manage to install SSH if you have blank hassio tab?
I suppose you are having different problem than the one discussed here.
Anyway, the way of rebooting I have suggested is from the web UI which you can find in the left menu at the bottom under “Services”. Choose service “hassio.host_reboot” and hit “call service” button.