Hass.io + command_line sensor - need help

Hi all,

I’ve spent a lot of time trying different things and searching for stuff, but I simply cannot get this very simple thing to work. Im running on a rpi3 with hass.io version 62.1.

So, I have a TV that I want to pull some json information from, and for that I have set up a command_line sensor.

I can get the data i want by running this command in the terminal via SSH: curl -X GET -H 'Content-Type: application/json' '' | jq '.sources[0] | .[1] | .product.jid'

This gives me this response: "[email protected]"

I tried to set this command into the command-line sensor with no luck. I’ve also tried to put the command into a .sh file and call it from the sensor with:
bash /config/scripts/beoinfo.sh,
sh /config/scripts/beoinfo.sh and also just
but all I get in the log is: Command failed: sh /config/scripts/beoinfo.sh

Can someone maybe point me in the right direction?


PS: The RESTful sensor does not work for the little project I’m trying to do, because I need to be able to change the TV’s IP address from the frontend :slight_smile: But first I need to get the basics working!