Hass.io Configuration and UI Link missing


since the last Updates the Hass.io Link is missing from my menu.
If I add “hassio:” to my config file, I get an “Invalid Config” message on my Dashboard.
If I remove the single line “hassio:” from my config, the message is gone.

Changelog doesn’t mention any breaking changes and since the poor choice of naming it is nearly impossible to find anything via the search function.

Is this anywhere documented?
The only reference I can find is: https://home-assistant.io/hassio/installation/

Can somebody please point me to the docs, any suggestions?

1 Like

To show the hassio menu you must include hassio: in your configuration, first level, no spacing before, no indented items after. You should try to figure out why you get the error if you add it.

It is included first level, no spacing, no indented item after:





This started to happen after an update, I don’t remember changing anything (but can’t rule it 100% out).

hassio homeassistant check doesn’t show any error:

core-ssh:/config# hassio homeassistant check
Success homeassistant/check

Still the Dashboard tells me to check the config.

The Log includes the following:

Error during setup of component hassio
10:23 PM components/hassio.py (ERROR)

Details to this message are:

Error during setup of component hassio
Traceback (most recent call last):
File “/usr/lib/python3.6/site-packages/homeassistant/setup.py”, line 196, in _async_setup_component
result = yield from component.async_setup(hass, processed_config)
File “/usr/lib/python3.6/site-packages/homeassistant/components/hassio.py”, line 172, in async_setup
if not (yield from hassio.is_connected()):
File “/usr/lib/python3.6/site-packages/homeassistant/components/hassio.py”, line 262, in _wrapper
data = yield from funct(*argv, **kwargs)
File “/usr/lib/python3.6/site-packages/homeassistant/components/hassio.py”, line 333, in send_command
X_HASSIO: os.environ.get(‘HASSIO_TOKEN’)
File “/usr/lib/python3.6/site-packages/aiohttp/helpers.py”, line 99, in iter
ret = yield from self._coro
File “/usr/lib/python3.6/site-packages/aiohttp/client.py”, line 275, in _request
resp = req.send(conn)
File “/usr/lib/python3.6/site-packages/aiohttp/client_reqrep.py”, line 463, in send
writer.write_headers(status_line, self.headers)
File “/usr/lib/python3.6/site-packages/aiohttp/http_writer.py”, line 247, in write_headers
[k + SEP + v + END for k, v in headers.items()])
File “/usr/lib/python3.6/site-packages/aiohttp/http_writer.py”, line 247, in
[k + SEP + v + END for k, v in headers.items()])
TypeError: must be str, not NoneType

Hello, I came here to report a similar issue.

I am a newbie to Home Assistant and hassio, so I just followed the ‘Installation’ instructions. Everything worked great.

So I moved on to the next section - Configuration - and that’s where the wheels fell off…

I can access my lovely new HA installation, I can select the menu icon at top-left, I can click on the ‘Hass io’ link in the menu. But then nothing happens. The browser’s URL changes to http://hassio.local:8123/hassio/dashboard, but the page is empty (except for the menu which is still expanded).

So does this seem like a glitch with the latest version? (HA v0.62, latest version of hassio as of half an hour ago, which is when it would have activated and updated itself.)

Could you please stop derailing the thread?
This is completely unrelated.

Still as a starting point: Check your Browsers JS console and the network tab of the Dev-Tools.

Was that comment/request directed at me?

@eddi89 : Thank you, yes I am using uBlock Origin (Firefox), though I did disable it (first thing I tried when it didn’t load). Looks like you are onto something though, as when I tried Edge it does look different. So I thank you, I’ll keep troubleshooting on that path.

@echox : In case your “stop derailing” comment was aimed my way… really, dude? That’s how you respond to someone who a) is making their first post here, b) is asking for help, c) is unfamiliar with this tech, and d) is trying to add information that may be related to the bug you reported in case it helps others in solving your issue? If you represent the community here then I’m off to OpenHab.

@CJB please don’t feel bad, there’s people here from all over the world and sometimes writing in English make messages seems rude. There’s a lot of friendly people here, feel free to ask your questions.

About your problem, it seems unrelated to echox, as you can see the hassio menu. After every update alway clear the browser cache and reload the page. I experienced a similar issue with safari (hassio page not loading, errors in javascript console) until a full page reload.

@echox never seen that error before, sorry but we have to wait someone more knowledgeable

Thanks a lot for the kind words and welcome, @namadori, I will take (all) your advice. :slight_smile:

@CJB: As you can see, its my first posting in the forum here.
I wrote a small pull request a while ago and I’m using HASS for quite some time now.
Therefore I feel not like I represent the community here.

Yes, of course my reply was directed at you.
I pointed out to please stop posting unrelated stuff und this topic.
I also gave you a hint how to check and solve your problem (I don’t know exactly about uBlock, but usually you will get the hint “Request xy” was blocked by an extension in your Dev-Tools).

My intention was not to be overly friendly but also not to be overly rude.

Lets switch a little bit our perspective:
Derailing Threads is harmful. Not only here, its in nearly all technical related discussion media (Mailinglists, Forums, Slackchannels, etc.).
I’m grateful for every second a person I don’t know spends reading the description of my problem and may be able to help me a little bit. I try to describe the question accurate, be precise and strip unrelated information.

Every Post in a thread adds infromation and stuff other people have to read.
Maybe the solution was already mentioned, maybe some more context for the problem was added.
In this thread, the reader has now to skip 9 totally unrelated off-topic comments.
If you search for a solution of your problem you may find yourself browsing through 10 hits with 80 useless comments.
This is why staying on topic is important.

So with the other perspective:
There is this one guy, making is first post, derailing another persons topic, is super fast offended and behaves like he has bought some kind of product and is threatening his car salesman to go to the competitor at the other end of town. He also doens’t care about reading the FAQ before posting (https://community.home-assistant.io/faq#keep-tidy).
Just to be clear: I exaggerated a little bit…

(All that said I feel like I approved a lot of the cliches related to rudeness and efficiency of Germans).

1 Like

What happens if you remove the “hassio:” and instead write “discovery:”. Had the same/similar issue as you, but after adding that and restarted it worked for me. I didn’t have any errors, too.

discovery: also didn’t work.

During checking the Logs I noticed the version which was running on my Pi: 0.61.0.dev0
I have absolutly no idea how this got on my machine? I wasn’t aware that it is even possible to switch to the dev branch from a regular installation…

I did nothing special and usually just run hassio homeassistant update. Pretty strange…
After another manual update to the current version, the problem is gone.

Still: Can anyone point me to the documentation of the hassio: config tag?
Or is the link I posted the only place?

I think it’s only in the Installation page you linked. It has no documentation, but it is pretty straightforward: just put it in the config, it has no options or additional configurations.