Hass.io data dir reverted and hassio now running from default

Hi all, I just recently shifted on to hass.io using instructions as https://www.home-assistant.io/hassio/installation/#alternative-install-on-generic-linux-server for my Intel NUC.

The link there points to Github Repo here: https://github.com/home-assistant/hassio-build/tree/master/install and the documentation there points out how to change the data dir for hassio, which is what I used for my install.

Everything was going well, even over a few updates until I updated from 89b2 to 89.0. After the update, I lost all my config and the version running was 87.1.

After some digging it seems that hassio has reverted to loading from the default source of /usr/share/hassio. I want my source located at /opt/hassio.

I know I can symlink it but would rather understand how to change hassio config to run from the alternate location.

Can anyone offer guidance?

My guess is since that is a command line option for the install script that you hit a bug where the latest update version ignored that setting when installing the docker container.

I would file a bug report issue against hassio.

Issue #149 reported

1 Like

Interesting thing is that hass.io install creates a hassio.json file in /etc which has the location of the overriden datadir. That file had been overwritten too. When I checked it after the update it had the default data dir in there. I tried changing it to the correct one and reboot but the containers are already rebuilt linking to default dir.

I’ve gone through the build script but can’t figure out how to rebuild them manually.