Hass.io DEAD!

So I’ve been running homeassistant for about 8 months or so now on a raspberry pi 3 B+ with no real issues. Today I was poking around in grafana and it suddenly became unresponsive and eventually lost connection. I haven’t been able to get it back up since.

It will not ping so I have no way to access it.

I’ve tried power cycling it a few times. Didn’t work.

I’ve checked the router to see if it had a new IP address but it’s not even there. (I have a static reservation for it so it shouldn’t have gotten a new IP anyway).

I checked the switch port and it does have a link.

The power lights on the raspberry pi do come on like normal.

The light ring on the zwave stick lights up and changes colors like normal.

I’m not sure what to do next. I’ve done some searching on the forums and some suggest checking the SD card. How do I go about checking it? Can I just plug it into my windows machine and do some kind of disk check? Also, if it helps, I do have some recent backups stored in cloud storage. Not exactly sure which version I was running. I updated it a couple of months ago so it’s somewhere around 0.9-something.

Anyone have any ideas on what steps I can take next?

The file systems on the SD card are not readable by Windows, but if you have a Linux VM or a Live Linux CD, you can mount the SD card and access the files (hopefully). If it doesn’t boot, then you probably need to recover/retrieve the configuration files from your backup, replace the SD card and rebuild it. Once you are up and running, you can apply your backups.

                    I have seen the light !!!!!!

Back up regularly AND especially before/after any major change

                    I have seen the light !!!!!!

So rebuild I assume you mean re-install from scratch like I did when I first loaded it on the pi, right? I don’t know if I even remember what I did. But I’m sure I can find it.

So that’s what I did. New SD card and loaded the hassio image onto it. I tried to reuse the old SD card but it just wouldn’t take the image. Once hassio was up and running I installed ssh and smaba.

Using ssh I reverted to the last version I was using. To match the snapshots I had saved.

Then using samba, moved my latest snapshot into the backups folder, refreshed the snapshot screen, selected my snapshot and restored.

Still have to clean up a few things like my ecobee thermostat needed to be re-registered and I’m having issues with mariadb not connecting. But other than that, the process went smoothly. I think I’ll keep another sd card on hand as backup for when this happens again. Then look into getting a nuc or something a bit more robust to run HA on.