HASS.IO Docker?


#22

Yeah that’s what I had essentially done.

I had a docker image named hassio, which installed avahi and everything else like socat and jq.

It would then start the install script, which would kick off the systemd calls. But that would fail as systemd can’t run inside a docker image.

systemd ins’t available for alpine, so I changed the base image from Ubuntu to the official Docker base image, which is based off alpine. However you need to use the alpine equivalent of systemd, which I couldn’t get to work properly inside the container.


#23

Sorry for the late reply, no I didn’t unfortunately. I’ve been informed I can install HASSIO in a virtual environment (guide on here somewhere) but my Synology is not in the right state to use Virtual Machine Manager at present so not tried that route.

Still hoping someone who knows a lot more about this than me can come up with a ready to roll docker install though. Looking at you @philhawthorne :wink:


#24

This might be a bit overkill, but what about:
creating a docker container with lets say ubuntu that runs on the synology nas.
That Ubuntu instanstance runs home assistant with hass io and everything you need.

Any thoughts on that?


#25

I attempted that. Got pretty far, but then couldn’t get hassio to start.

Hassio uses Supervisor, which can’t be run inside a docker container. It needs to be running on the host. Which makes it tricky to install on the NAS


#26

`Hey Phil, did u mamange to get this sored or what did u end up doing, i am facing the same issue trying to run hssio on a qnap nas on container station using the option amd64-hassio-supervisor-1 within docker and it installs but does not start up. did u end up installing linux first and the hassio


#27

Looking to do the same thing on unRAID docker with Hass.io. I have the Home assistant standalone docker container but feel like Hass.io would be a better way to go.


#28

Unfortunately not. I did some research and there’s a big problem trying to run supervisor within a docker image.

I installed a ubuntu container, with the intent of just doing a standard HASS.IO basic linux install, but ran into the Supervisor issue.


#29

Does the recently announced HASSIO OS make any of this any more viable? I’m guessing from the tweet I received from Pascal Vizeli it might not.


#30

I just wanted to add the code here of where we are getting stuck.

Install start-hassio

echo “[INFO] Install startup scripts”
curl -sL “$URL_START_HASSIO” > “$BIN_DIR/hassio-start”

sed -i “s|%%SUPERVISOR_IMAGE%%|$HASSIO_DOCKER|g” “$BIN_DIR/hassio-start”
sed -i “s|%%HOMEASSISTANT_IMAGE%%|$HOMEASSISTANT_DOCKER|g” “$BIN_DIR/hassio-start”
sed -i “s|%%DATA_SHARE%%|$DATA_SHARE|g” “$BIN_DIR/hassio-start”

chmod a+x “$BIN_DIR/hassio-start”

Init system

if [ “$INIT_SYSTEM” == “systemd” ]; then
echo “[INFO] Init systemd”
curl -sL “$URL_SERVICE_HASSIO” > “/etc/systemd/system/hassio-supervisor.service”
curl -sL “$URL_SERVICE_HOSTCONTROL” > “/etc/systemd/system/hassio-hc.service”

sed -i "s|%%BIN_DIR%%|$BIN_DIR|g" "/etc/systemd/system/hassio-hc.service"
sed -i "s|%%BIN_DIR%%|$BIN_DIR|g" "/etc/systemd/system/hassio-supervisor.service"

systemctl enable hassio-supervisor.service

echo "[INFO] Start services"
systemctl start hassio-hc.service
systemctl start hassio-supervisor.service

fi


#31

Have you made any progress in that sense?

I’m not liking the responsiveness of my RaspberryPi Hass.io and it seems the SD card finally gave in this morning (or the Pi itself, haven’t had the time to look into it yet), so I decided to look into (re)creating it all on the home unRAID server.

I’ve seen it done in an VM (diyfuturism dude) but would first like to try what I imagine is a bit more direct aproach, doing it directly in unRAID docker(s).


#32

Im really interested at this.
I own a Micro Server with Xeon and Server grade hardware where I run Unraid in it.
I would love to move hassio to the docker or to a VM at least so I can free up my pi3 for something else (looking at DIY 4k Ambilight)


#33

I have a FreeNAS system that uses RancherOS for a docker host. I am brand new to it and haven’t actually used any dockers so I’m not sure what is and isn’t possible. Is it possible to use the docker images linked above since there are hassio supervisor, homeassistant, and addon images?


#34

A lot of attempts have been made by people who know a lot more about docker and the underlining Home assistant architecture than me and they have come up which issues while trying to get it to work.

You’ll be better off using HA under docker for now, like myself and a lot of others like @philhawthorne.

Give the store.docker.com a search for homeassistant or better still have a look at @philhawthorne’s blog.


#35

so… so far installing “hass-io”(https://github.com/home-assistant/hassio-build/tree/master/install#install-hassio) via docker, it’s not working… :\ what a pitty
I have tried myself in OpenMediaVault, and cannot find a way of make it work


#37

Hello, I know your post is quite old. I was able to get hass.io installed and running, but once I shut it down the docker container for it disappeared and will not come back. I see the hass.io supervisor container, but hass.io is not running nor am I able to figure out how to get it to run. Any insights?


#38

I think I’ve had that issue couple of times. for some reason the supervisor container ‘thinks’ that the home-assistant container is valid and doesn’t fir it up again. Haven’t spent lot of time to check the why but what I’ve done is to remove the supervisor again and fire the installation again. That solved my problem.

Also, do a copy of your Config, etc before running this…


#39

I found that I had to delete the volume for Home Assistant and restart the supervisor to get it to restart.


#40

Right, actually when you said that I realized that I’m deleting also the volume for the supervisor container. never tried to remove only the volume but makes a lot of sense as i guess it’s storing some cache information that is exactly what is wrong.

when that is deleted the supervisor will restart all the processes included the home-assistant contaner :slight_smile:

nice!


#41

@roofuskit @davedan Sorry guys just catching up with this post, are you saying that HASS.IO is possible within docker now? excited face


#42

Yup, actually it’s based on Docker (https://www.home-assistant.io/hassio/). I have it running along with other containers in my server.