Home Assistant Community

HASS.IO Docker?

#43

That sounds great, Are you planning on putting a tutorial together?

#44

If you’re planning on running it on Synology, I don’t think @davedan’s solution will help.

It has always been possible to run HASS.IO as Docker. This requires you to install Supervisor to your Server/Box. However, for us Synology folks, we want to run Supervisor inside its own Docker container, which is currently not possible.

Essentially what is currently supported:

Host Machine
   - Supervisor / HASS IO
      - Docker
        - Home Assistant
        - Addon One
        - Addon Two

What we Synology folks want/need is

Host Machine
  - Docker
    - Supervisor / HASS IO <-- Running in its own container, controlling sister containers
    - Home Assistant
    - Addon One
    - Addon Two
1 Like
#45

correct, as per my post above I run this on an Ubuntu Server, I’ve never been able to have this tunning on my Synology :frowning:

sorry, maybe I should have been more precriptive on my post.

1 Like
#46

I did think it was too good to be true :smiley:, thanks anyways @davedan and @philhawthorne

#48

error only systemd is supported how did you overcome this? i ran

curl -sL https://raw.githubusercontent.com/home-assistant/hassio-build/master/install/hassio_install | bash -s

from putty ssh to synology nas as admin then “sudo su” Password… in DSM6.1+

#49

First, I didn’t run it that way ( never run anything that I can’t review first ). so I always download the script, review it, adapt it and then execute.

Can you try to do a curl -sL https://raw.githubusercontent.com/home-assistant/hassio-build/master/install/hassio_install first, and then run it with ./hassio_install (as you’re already su )??

As per my post I wasn’t unable to make this work in Synology. Do you happen to have another place to test?

#50

Try to run install by login in with root instead of sudo I install it like that on my Ubuntu server Docker

1 Like
#51

Struggling to install it on an intel Nuc with ubuntu server 18.04 installed.

Supervisor service won’t start because of docker error :

docker.dockerd[1279]: time="2018-12-10T16:25:22.727326655Z" level=error msg="Handler for POST /v1.38/containers/34c9700e0cdd0af28159058873795c4c7ba2654527b9e38ba4fbaf
8d46130dea/start returned error: error while creating mount source path '/usr/share/hassio': mkdir /usr/share/hassio: read-only file system"

Any helps appreciated.

#52

Hello @frazha use these commands to get the installation done on you Nuc

Run these commands in the same order

|sudo -i|
||add-apt-repository universe|
||apt-get update|
||apt-get install -y apparmor-utils apt-transport-https avahi-daemon ca-certificates curl dbus jq network-manager socat software-properties-common|
||curl -sSL https://get.docker.com | sh|
||curl -sL “https://raw.githubusercontent.com/home-assistant/hassio-build/master/install/hassio_install” | bash -s|

#53

Hello , i have tried but it’s not working
As a workaround, i deactivated apparmor and it works fine.

Thanks

1 Like
#54

Docker HASSIO Image size?

Has anyone been able to change the amount of storage allocated to the HASSIO disk size?
Docker is working fine but the disk is not large enough.

#55

My understanding is that systemd is used to launch the supervisor and restart it if it fails but the same can be done without systemd as well. The supervisor itself runs as a docker image. So this seems very doable.

I’m just dipping my toes into Home Assistant and just playing around with various ways I can deploy it. One of places I tried to deploy it was my QNAP NAS. I was able to successfully deploy it install and manage addons and play around with Hassio CLI . So it should be doable on a Synology NAS as well. The reason I decided not pursue it further was I did not want to dig into how to play around with the init system used by my QNAP system. It seems quite archaic to, for a lack of better term, systemd-fanboy like me.

This is how I launched it on my QNAP hopefully same should work on Synology as well. I realize that they are two different systems but work within mostly same constraints of a non-systemd based linux systems.

docker run -d  --restart unless-stopped --name hassio_supervisor --security-opt seccomp=unconfined  -v /var/run/docker.sock:/var/run/docker.sock -v /var/run/dbus:/var/run/dbus  -v /usr/share/hassio:/data  -e SUPERVISOR_SHARE=/usr/share/hassio -e SUPERVISOR_NAME=hassio_supervisor -e HOMEASSISTANT_REPOSITORY=homeassistant/qemux86-64-homeassistant homeassistant/amd64-hassio-supervisor

Notes/Caveats :

  1. –restart unless-stopped will make sure that the supervisor is restarted if the container dies/is killed unless I explicitly stop it using docker stop
  2. I still needed to configure the init to launch this command on reboot of my NAS but I did not have patience to learn SysVinit like init of QNAP. Perhaps @reboot in cron might have been sufficient.
  3. I still needed to (either through the init or a script) make sure supervisor is relaunched should the docker container dies due to some coner case like issus with Container Station on QNAP as in that scenario I cannot trust --restart of docker run
  4. I have only tested this on QNAP and have no experience with Synology but in-theory it should work similarly assuming you have docker installed and have ssh access to the box
  5. I am very new to HomeAssitant I have not integrated anything into it nor have I had a long running instance of home assistant on my QNAP. So what I did was not a comprehensive test
  6. Things I tested and worked successfully were accessing the UI, installing addons, uninstalling addons, using Hassio CLI
  7. Port 80 on the NAS systems is usually used by the UI for the system so if you wanted to hit the Hassio (not homeassitant) API over the LAN instead of locally on the box you might want to map port 80 inside the container to another unused port on your NAS like so -p :80 in your docker run

If anyone is interested in running this with docker I can try and help. I would not be able to help with setting up init to launch on boot as I’m not familiar with init systems these NAS machines use. I can try help with docker or scripts.

#56

Maybe off-topic, but on Synology you can also launch virtual images like esxi or hyperv , so why not use the HassOS? Then you have everything you need?

#57

This is true actually, and probably the best way to do it for Synology users.

However just a heads up that you’ll need to re-format your harddrive for those virtual images to work on Synology. If you’ve got a lot of data already on your NAS, it might be difficult.

1 Like
#58

Is there someone that used a docker-compose.yml file in order
to install Hass.IO docker in ubuntu please ?
I have a Qnap with virtual OS Ubuntu and I just want to test Hass.IO on more powerfool machine

Thanks a lot all
Denis

#59

Then just install hassio. You don’t need docker-compose for it, nor would it do you any good.

#60

Thanks for the answer
I don’t know why I have not received email from you answer :frowning:

Anyway yesterday I just install the Hass.IO via docker exactly from the link you provided :slight_smile:
It’s work and it’s so quick :slight_smile:

I have another problem now…
I installed the LetsEncrypt addon but when I start it then it do nothing.
I push Start button and after 2 seconds it stop… with no log under the page.

Maybe I’ll open a new thread with this problem.

Thanks again
Denis

#61

This is one avenue I wanted to go down but my drives are too full and Synology don’t offer a migration process to the format needed :-1: