Hass.io ESXi and bluetooth

Hi all,
I’ve migrated my Hass.io installation from a Pi 3b+ to an ESXi server.
I’ve used this tutorial to install Hass.io:

I’ve reverted my Snapshot and everything works fine. The only trouble I have is with bluetooth. I’m using a bluetooth USB stick with passthrough to the Hass.io VM.

But I dont know how to tell Hass.io to use the stick. Can someone help me with this issue?

1 Like

I have same issue… :roll_eyes:

are you running an HP micoserver?
i also have esxi on there, and had trouble to passthrough the deconz usb stick, look like it was detected, but deconz could not find and devices
after hours of trying, tried another USB port , and was fine
i think it maybe had to do with the usb controller or mainboard

I’ve got a hp microserver at work with proxmox on. When I plug disks into the usb3 ports they kinda work, get power, can mount and read directorys, but writing or copying files to/from them cause them to give me I/o errors. The other ports are fine.
Normally it’s some driver/chooser issue (best I can work out)

As above, try using other ports, even the ones on the front, as they might be using a different controller

Hi @cooljimy84 @pergola.fabio ,

I’m using the front USB port on an Intel Nuc. Does anybody of you do some further steps not mentioned in the tutorial to “install” the bluetooth device inside hass? I only installed the bluetooth debian package but I dont know if this is enough. What Bluetooth Sticks did you guys use?

Hey all,
I did some test and I have some observations to share:

When I start my Hass.io server attached with the USB stick for Bluetooth it is impossible to load lovelace. I’m only getting:
"Loading Data"
When I start a SSH connection to the VM and try to make a bluetooth scan with:
hcitool lescan
I get the following error message:
Set scan parameters failed: Input/output error
This status didnt change.

The only thing i can do is to disconnect the bluetooth stick or to restart the bluetooth service in debian
service bluetooth restart

After this command lovelace is loading and some of my MiFlora Sensor have some values in it 0o. These values didnt change during the runtime of Hass and when I re-run the steps above I get values for another MiFlora Sensor. In the SSH session I’am also able to make a scan with hcitool lescan

It seems like there is a problem with the bluetooth connection and/or Hass.
Did someone have a hint for me to investigate this further?

why are you not using HassOS on your server, its verry easy for esxi!

I have have Hass.io install running on ESXi (converted the vmdk). The issue is, bluetooth dongles do not work - z-wave usb works fine however. I’ve bought and tried 3 dongles without luck. Sucks.

1 Like

Hmm , strange, not an issue with esxi I think, since it’s a passthrough…
Maybe a driver issue on hassos?

Moved to Debian 9 + Hass.io

Still had a headache getting bluetooth to work, but got there in the end!

Did you manage to get anywhere with this or did you end up sticking with Debian?

I have fixed my USB issue I had before by using the back USB port , not the front on my hp gen 8 server