Hass.io fails to connect after installing duckdns

So I left Hass.io for a bit as it was too complicated for my limited knowledge and I had loads of problems.

I then thought I would come back to it, so have started from a fresh install and am working through this video:

I have installed Hass.io
I have added the samba add on, and can connect from the mac.

I have just installed Duckdns and added this code:

  base_url: https://xxxxxx.duckdns.org:8123
  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem

XXXXX is the duckpins username I have. I saved, I restarted Hass.io and I now cannot connect to my pi using http://hassio.local:8123 or using Duckdns

The log shows:

2019-06-09 21:37:01 ERROR (MainThread) [homeassistant.core] Error doing job: SSL handshake failed
Traceback (most recent call last):
File “uvloop/sslproto.pyx”, line 500, in uvloop.loop.SSLProtocol._on_handshake_complete
File “uvloop/sslproto.pyx”, line 484, in uvloop.loop.SSLProtocol._do_handshake
File “/usr/local/lib/python3.7/ssl.py”, line 763, in do_handshake
ssl.SSLError: [SSL: HTTP_REQUEST] http request (_ssl.c:1056)

No problem, I thought, I will access it over samba, # out the bits I added, but no, still cannot access Home assistant.

What have I managed to mess up already?

Now for some reason I can access my Hassio using Duckdns but can not access it using http://hassio.local:8123

This is driving me crazy. I remember last time part of the initial setup made it go from http to https but I have not done that yet, and tried https just to be sure and that does not work, so why does http://hassio.local:8123 not work now?

I’m having similar issues. I’ve been using DuckDNS and hassio for a long time now, but after deciding to do a fresh install I haven’t managed to get it to work. I’ve done the re-install numerous times now, and tried every combination of settings and http configs recommended in other threads, but I just can’t get it to work.
I realise this post doesn’t help, just needed to get that off my chest :slight_smile:

for the local access, you still need to use https , you will get the errors about not a secure address, but you can click through (at least on Safari) and access it.

Question then, what makes logon change from http to https?

I have been accessing it through http to begin with as https was not working.

Now if I go to https it asks me to login with legacy password which I thought had gone in new versions of HA and when I do logon with my logon details it says error, while if I try and connect through http it just blank screens and says cannot be found

When I tried this on my system, and pointed my browser to https:mylocalip:8123 I was prompted for my userid and password, just like I would from a new browser using the external address.

Do you still have a reference to the legacy password in your config?

I will give it another go when I get home. Last night https and http were not working but then neither was duckdns for a bit and thats working from the office and accessing Hassio via terminal was working last night so fingers crossed its something minor.

I have a new install so no mention of a legacy password as far as I can see, this is my entire config so far…

# Configure a default setup of Home Assistant (frontend, api, etc)

#I added base_url, ssl_cert and ssl_key for Duckdns

  base_url: MYURL.duckdns.org
  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem

# Sensors
  # Weather prediction
  - platform: yr

# Text to speech
  - platform: google_translate

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml