Hass.io Installation Error


#1

Hi. I am super new to Home Assistant. So I got a Raspberry Pi 3 Model B, a 32GB Samsung micro SD card.

I followed the instructions detailed in this page:

I downloaded Etcher and the appropriate image for my device and flashed the Samsung card.
I then connected by Pi to my TV via HDMI, connected it via ethernet to my LAN, and booted the thing up.

I see a lot of command line stuff going on for 10 minutes but then the installation gets stuck with this:

[1941.610320] IPv6: ADDRCONF (NETDEV_UP): wlan0: link is not ready
[1941.621765] BRCMFMAC: power management disabled

Then the setup would keep repeating these 2 lines.

Here’s how I tried to fixed the issue (and failed):

  1. I tried re-flashing my SD card with Etcher but somehow, my installation gets stuck on this part.
  2. I thought this was a hardware issue so I installed Rasbian on the Pi and I was able to browse the web when connected via ethernet. So I think the hardware is fine.
  3. I tried going on my router interface and assign a static address to my Pi but this did not fix the error.

What am I doing wrong? Why do I keep getting this error?


#2

You need to stop rebooting and reflashing and wait!!!
Also don’t connect via HDMI - nothing useful is shown there after if first says it’s installing.
Just go to http://ip_address:8123
It could take longer than 30 minutes for it to come up and be working.


#3

I actually left it overnight and it got stuck there.


#4

same problem here. Tried it with 2 sd cards with a freshly downloaded hassOS (32Bit Raspberry 3)


#5

Did you get stuck at the same part? Were you able to figure it out?


#6

Same thing happens to me and it’s the 2nd card I mess up… two nights waiting and nothing besides “Preparing …20 minutes”. Can’t use card for anything else, can’t delete partitions. Already tried with gparted (linux) and diskpart (windows). Nothing can make the cards writable again.


#7

I think I can reflash the sd card, but my system is stuck here:

cannot access the web-hass os. Newby here. How can I get HASS IO / HassOS to run?

Had an earlier version that worked for a few months, but did not use it, that had stopped and I assumded the SD card was broken (had no monitor in range of my RPi). So I removed it from my home automation box and set it to my desktop (/Monitor with hdmi). Installed a new sd card. And voila I´m stuck with the line above.


#8

Same problem here!
Still no solution. I don’t know if it relevant but I came accross to that:
https://github.com/home-assistant/hassio/pull/581

but I have no idea what they are saying there… :yum:

I forgot to say that this issue apeared after power failure.


#9

Unless you intended to use wifi and IPv6 instead of IPv4 this message is not a problem.

Power Management being disabled is also not a problem.

Normally you don’t look at this console at all. It’s a server, so you open a browser and go to the local-ip-address:8123 and wait.

I don’t know how you are doing this, but in Windows you would select the disk in diskpart and then ‘clean’ it. You could also use an SD format tool like this one https://www.sdcard.org/downloads/formatter_4/

You’re the first I’ve seen where flashing an SD has resulted in SDs becoming unwritable. I’m not saying you are wrong, but I think it is odd. Do you use an adapter that “locks” the SD?


#10

I have had I think one dead card that just wasn’t being recognised and nothing would bring it back - so I replaced the card, end of problem.

SD-Cards can be a bugger at times but they can break - but they’re pretty inexpensive so if this happens just replace. I have re-imaged cards more times than I can count with no issues though including deleting all partitions so it’s not a regular occurrence.


#11

Waiting the browser led nowhere after many hours.
Can’t reach UI in any way…


#12

Wow. I feel so stupid. I was watching the monitor connected to the Raspberry PI. I didn’t realize I was supposed to go to the web interface on my PC. It was waiting there for me all along without any issues!!!


#13

And you connected to home assistant?


#14

Yes. Thanks!


#15

how do you configure the hass io to connect to the wifi?


#16

I got stuck to the same place, and I checked my router, finding that Hassio did not connect to the network at all. Then I resolved it by renaming my USB drive (for /network/my-network) to be “CONFIG” (no quotes).


#17

2019-01-05 19:33:52 INFO (MainThread) [homeassistant.core] Starting Home Assistant
2019-01-05 19:33:52 INFO (MainThread) [homeassistant.core] Timer:starting
2019-01-05 19:34:05 INFO (MainThread) [homeassistant.components.discovery] Unknown service discovered: igd {‘host’: ‘192.168.1.1’, ‘port’: 5431, ‘ssdp_description’: ‘http://192.168.1.1:5431/dyndev/uuid:34bf9047-b4a6-a6b4-4790-bf34bf47a60000’, ‘name’: ‘AN1020-25U’, ‘model_name’: ‘96318REF’, ‘model_number’: ‘AN1020-25U_R2A’, ‘serial’: None, ‘manufacturer’: ‘FiberHome’, ‘udn’: ‘uuid:34bf9047-b4a6-a6b4-4790-bf34bf47a60000’, ‘upnp_device_type’: ‘urn:schemas-upnp-org:device:InternetGatewayDevice:1’}


#18

I am having the same issue. I removed my touch screen and PoE head as it appeared to be causing a drop in power (got the lightning bolt) and have reimaged my SD over 4 times. I get the screen indicating it could take 20 minutes, but I let it run overnight and still not coming up. The “preparing Hass io” screen appears stuck and just white. When I stop the browser window and refresh I get the logo 20-minute wait screen and it eventually changes to the white screen.

I have tried both 32-bit and 64-bit versions.


#19

Hi, I’m new and I have the same problem
I have a Raspberry Pi 3 plus. I can see the hassio in my router, but when I try to access it, the page says that the site cant be reached.
I connect the raspberry to a monitor and the process is looping on:

IPv6: ADDRCONF (NETDEV_UP): wlan0: link is not ready
BRCMFMAC: power management disabled

Does anyone solve this issue?

Thanks


#20

I fixed it by rebooting rpi and make sure the wifi usb is plugged in before i turn rpi back on