Hass.io installation fail - "no ethernet found"

I decided to give Hass.io a try as there are many questions on this and other forums around hassio. I’ve been using the same Pi with Home Assistant in Docker as my dev environment for a few months now, no problems at all.

I downloaded the RPi3 32 bit Hass.io image v1.11 from the installation page, unzipped it and burned it to a micro sd card with dd. Inserted the card and plugged in the power cable, leds start blinking but before I have a chance to sit down again the installation fails with a message Net: no ethernet found. My Pi is connected with a cable to a switch and has been working fine before but when I check my router, no IP address has been awarded.

Alright, there might be something wrong with the image? Downloaded v1.12 (current) and tried again: exactly the same error message. Took an old USB stick, formatted and created the network/my-network file as instructed: same error message.

Any clues or suggestions on how to solve this?

See if this helps:

With wired ethernet it should just work - the default is to get a dhcp address on the ethernet port.

Try another cable, make sure both ends are plugged in (yes I have been there!)

Well, the cable works fine when I use another SD card so I don’t think that’s the problem. Unfortunately I only have two SD cards: one 16 GB running Raspbian Lite and HASS in Docker and one 8 GB that I thought I’d use to give Hassio a try. I was hoping I wouldn’t have to swap cards but I’ll give it a go anyway.

Now where is my SD card reader? :slight_smile:

Still no success. I reinserted my 16 GB card with Raspbian to ensure the cable was working (success) and then reflashed the card with HASSIO v1.12 using Etcher. No success.

Tried reflashing the card once again, this time with dd. 8 partitions are created but my RPi won’t boot. :frowning:

I think problem is that, you flash RPi3 version of Hassio on RPi2 model or vice versa.

I wish it was that easy but the file I downloaded is named hassos_rpi3-1.12.img and my Pi is definitely a v3.

I have the same problem here. Just bought new raspberry 3b+ and 32 class 10 sd card. I am using wired ethernet. Does anyone know a fix to that?

After an entire day suffering I decided to change my power supply and… voilá… it worked… I am very mad at me because I bought a weak power supply… My Motorola Turbo Charger Handled the Job and the one I bought did not… I suggest you try to change your power supply and try installing via wifi, that might help you.

Has anybody a real solution for that problem? I tried different power supplies but nothing changed. Also tried different hass.io Versions (1.13/1.3/2.7/2.11).

Putting some network config on a USB-Stick does not help either…

I’have the same problems.
Is therne no solution?


I just installed hassio manually with a normal raspberry pi image. It was no real problem and works just fine

Same problem here (adding Card did not respond to voltage select)

But! Eureka! I had tried with different SDCARDS, USB adapters, power adapters including original,32vs64bits version. Different SDCard formatting tools… BUT,the rule was to read instructions with careful. I didn’t know rPi3b+ had sd card slot. Is under the board!! So when I readed instructions of suggested hardware, between things you need to have your Hass.io host, there was an sd card to usb stick.


We will need a few things to get started with installing Home Assistant. The latest Raspberry Pi model makes a good and affordable starting point for your home automation journey. Links below are linking to Amazon US. If you’re not in the US, you should be able to find these items in web stores in your country.

Ok ok, Sd Card reader to format it in your PC, not to connect it to rPI. Could you specify in other way to avoid confusion?

  1. Unmount the SD card and remove it from your SD card reader.
  2. Insert the SD card into your Raspberry Pi 3. If you are going to use an Ethernet cable, connect that too.

The instructions are clear enough I believe. With the confusion being caused by not knowing there was an SD card slot on the RPi i’d say the instructions do not need changing.

1 Like

Really? You think people need to be told to add the SD card with the operating system on it to the slot on the pi?

I sloted it into the rPi trought usb sd card reader converter (which is in the list of suggested hardware), and yes,without knowing below the board is an sd slot. Normally not visible. I thought sdcard reader fitted here to install OS.

And @CBRHerms, those words you write would be great if they would exists here:

I don’t know from where did you get it. So I keep on thinking web I linked and suggested hardware site needs to be clear as crystal.

You mean like

For image-based installs insert the SD card (and optional USB stick) into the device.

Maybe is for my english level, but for me device can also be the sd-usb converter. Moreover, in implicit way, it can be trought this device according to the apparent absence of sd card slot.

Weird quoting you are doing.

How the hell do you think the raspberry pi is going to function without the boot device? This is not rocket science. The rpi is a well known device and it is very basic that it runs off the SD. However if you think the instructions are not clear enough, there is an “edit this page on github” link on every page of the docs.

I know it runs off the SD. But if you don’t see SD slot, and I have bought an usb-sd converter because is in suggested hardware… so mistake can be: connect SD to sd-usb and connect it to usb rPI slot. That doesn’t mean “without boot device” or “rocket science”. That means runs/boot with SD connected to SD-USB. Is that so crazy? You will tell me, of course (So easy from expertise perspective).

Otherwise I think, you have to be more comprehensible. Can you put yourself on my (or any other user) shoes? : I’ve got two inputs.
1: Oh god here there is not an slot for SD.
2: Ok,hass.io tell me to use and SD, and in suggested hardware appears SD-USB converter.

What would you do? From this point of view, really,think twice,what would you do? You talk me like if I am crazy. But I think you have to think slow, and think: maybe (just maybe, I only say this to take into consideration, just discuss it together, collect other possible experinces), from that point of view, -not viewing sd slot-, user website inputs can be fitted wrongly in this way.

In addittion, error line: card did not respond to voltage select is quite confusing when you google it. It’s full os forum posts talking about corrupted cards, formatting software problems, ethernet problems, cards recommended and no recommended. Would be easier (and time saver) if it would say: no sd card detected.