Hass.io menu Empty

Not using Hassio, but I read on another thread adding hassio: to your configuration.yaml file fixes it.

oh really ! thanks - I’ll give it a try.

sure, if it does work post it.

Hi did this work for you?

I had/have the same problem. Started with a new install of .69 also a new install of .70 and .70.1. No Hassio-page simply won’t load. When inspecting the page I see an error the webcomponents-lite.js.map cannot be found. Only solution for me has been to use Chrome which I wish I did have to do… Same when loading in Firefox: webcomponents-lite.js.map not found…

@juan11perez - nope!

Same with all browsers updated…
Seems to have no solution, is there any other way to install add-ons?

What version of Hassio are you running?

Same problem and refresh does not help?
Running version 0,75.0 rasp3

Do you have ssh access? HassOS or ResinOS

I cant access the installed plugins since Hass.io is blank.
But I just tried Putty and yes I have SSH access.
Hass.io “standard Rasp3” image used, sofar updates have worked great but the last one seem to have broken hass.io menu?

ok then just use putty to update to 0.75.2
command:

hassio ha update

Perfect thanks everything works now!
So happy I installed both SSH and SMB access, that’s a life saver

yep without them when something goes wrong it’s a whole world of pain (but still recoverable incidentally)

I am on 0.75.0 and am stuck with this issue with no SSH agent. I tried:

  • restart from configuration page button
  • restart from hassio.host_reboot service in dev-service page
  • Safari, Chrome, Safari Mobile, Firefox (with hard refresh/clear cache/incognito)
  • adding hassio: to the config file

How to I get unstuck? I have a config with dozens of entities configured, and my host is not easily accessible so I definitely do not want to reflash.

Perhaps someone has a copy of custom-panel.js that I can inject in the page to run the update?

I accidentally #discovery along side other code and sure enough the tab went.
Just lucky enough the Samba add on was already running for me to find it and change it back.

It seems a recurring error, my recent update to 0.80.1 lost again the item menu.
Has someone gone into the same problem?

Same after update from 0.83.0 to 0.92.0b1.

Try updating the Hassio supervisor.

Also, there have been many breaking changes between 0.83 and 0.91. Review the Release Notes for all the intervening versions too.

Already did that (got homeassistant/armhf-hassio-supervisor:latest tag, it run tag 141, but latest in hub 160), but nothing changes.

Looks like hassio can’t connect to https://s3.amazonaws.com/hassio-version/stable.json to get the latest version of supervisor, possibly that’s why version 141 used.

Supervisor:

a0d7b954_appdaemon3,19-04-21 16:28:34 INFO (MainThread) [__main__] Initialize Hass.io setup,
19-04-21 16:28:34 INFO (MainThread) [__main__] Setup HassIO,
19-04-21 16:28:34 INFO (SyncWorker_0) [hassio.docker.supervisor] Attach to Supervisor homeassistant/armhf-hassio-supervisor with version 141,
19-04-21 16:28:36 INFO (SyncWorker_1) [hassio.docker.interface] Cleanup Docker images: [],
19-04-21 16:28:38 INFO (MainThread) [hassio.host.apparmor] Load AppArmor Profiles: {'hassio-supervisor'},
19-04-21 16:28:38 INFO (MainThread) [hassio.host.apparmor] AppArmor is not enabled on host,
19-04-21 16:28:38 INFO (SyncWorker_0) [hassio.docker.interface] Attach to image homeassistant/raspberrypi3-homeassistant with version 0.92.0b1,
19-04-21 16:28:38 INFO (MainThread) [hassio.addons.git] Load add-on /data/addons/core repository,
19-04-21 16:28:38 INFO (MainThread) [hassio.addons.git] Load add-on /data/addons/git/a0d7b954 repository,
19-04-21 16:28:38 INFO (MainThread) [hassio.addons] Load add-ons: 51 all - 51 new - 0 remove,
19-04-21 16:28:39 INFO (MainThread) [hassio.updater] Fetch update data from https://s3.amazonaws.com/hassio-version/stable.json,
19-04-21 16:28:44 WARNING (MainThread) [hassio.updater] Can't fetch versions from https://s3.amazonaws.com/hassio-version/stable.json: Cannot connect to host s3.amazonaws.com:443 ssl:None [Try again],
19-04-21 16:28:44 INFO (MainThread) [hassio.snapshots] Found 1 snapshot files,
19-04-21 16:28:44 INFO (MainThread) [hassio.discovery] Load 1 messages,
19-04-21 16:28:44 INFO (MainThread) [__main__] Run Hass.io,
19-04-21 16:28:44 INFO (MainThread) [hassio.misc.dns] Start DNS port forwarding for host add-ons,
19-04-21 16:28:44 INFO (MainThread) [hassio.core] Ignore Hass.io auto updates on dev channel

UPD: fixed by getting tag 160 supervisor image from docker hub, tagging it as latest and edit /data/updater.json inside with correct hassio and homeassistant versions.

But other addons, including core, stopped working. Need to go deeper.