Hass.io MQTT auto discover doesn't work

I got a problem with hass.io MQTT auto discover. It doesn’ t work. The Mosquitto broker Integrations page is empty. Enable newly added entities. is enabled.

And there is data in the MQTT broker:

Any suggestion what the problem is or how to debug?


What broker are you using ?
If you go to developer tools -> mqtt and publish something, do you see it in mqtt explorer ?


I see absolutely nothing in that would utilize Auto discovery…

Hass.io Mosquitto broker
No there is nothing in the developer tools.

Can you please explain? There is sensor information in the homeassistant tab. So why is that not working and how do I configure correctly?

Then you have first to get the connection between HA and mosquitto working.

Ok how do I configure this in Hass.io?

Please read the page.

None of the data hitting your broker right now is formatted in a way to utilize Auto Discovery

OK how needs the data to be to work with auto discovery. I had zigbee2mqtt working with auto discovery in home assistant. I switched to hass.io because it should work out of the box.

But first you have to configure your broker properly.

Read the link I posted. The data that is in the MQTT broker isn’t formatted for Auto Discovery to work…I don’t think the problem is with his Home Assistant connection to the broker.

I posted a link. I suggest you READ it.

If he uses developer tools -> mqtt publish nothing arrives in mqtt explorer, so the connection between HA is not working.
And in the initial screenshot under homeassistant I see the sensors , zigbee2mqtt creates autodiscovery automatic.

He said:

That seems like an assumption. I am going by what the MQTT screenshot shows.

@evs, can you post a screenshot of mqtt explorer with a sensor under homeassistant expanded, so we can be sure?

Something like this :

1 Like

MQTT autodiscovering needs a standard topic (default: homeassistant):
(<node_id> is optional)
Be aware of using root-slash, /homeassistant is a different topic then homeassistant.

For example, I use this for my Who is Home status sensor:
config topic: homeassistant/sensor/who_is_home/config

Example data (I use this in Node Red):
{ "name":"WhoIsHome", "platform":"mqtt", "state_topic":"homeassistant/sensor/who_is_home/state", "device": {"name":"Who_Is_Home", "manufacturer":"MQTT Hass.io", "model":"Custom", "identifiers":["Who Is Home"], "sw_version":"20190817"} }


Solved it. Reinstalled hass.io installed mosquito broker plugin and zigbee2mqtt plug and it worked straight away.

I didn’ t find any method for debuging in home assistant. The log info is limited. It didn’t show any problems with the MQTT interface. So making snap shots often en go back if there is a problem. Is somehow the only way to solve issues.

1 Like

Nice to see it is solved! :+1: