Hass.io no network connection on boot

Followed the installation guide but I cannot reach my pi 2 using http://hassio.local:8123
I have the pi connected with ethernet, but looking at the lights on my router there is no connection, i.e. no light

I use the connected devices page on my router to look for the ip address, but nothing appears… Have attempted flashing the image a few times with the same result… Have left it running over night… Screen is blank when connected to HDMI on boot…
Any ideas?

I performed a manual installation of normal hass with no problems so not a hardware issue.

I am also facing the same issue.
When i use Hassbian it work without any issues.

I’m having the same issue - Did anybody find a fix for this?

Tried on two different Pi 3’s now, both inside and outside my firewall, however it seems like there is no actual connection to the Pi over Eth.

UPDATE - Solved; the fault in my case seemed to be the SD card. I solved my issue by using a brand new SD card, exact same make and model as the “faulty” SD card. With the new card hass.io booted up and installed as intended.

Maybe Hass.io is a bit picky on the SD card side, to my knowledge there is no issue with the SD card it discarded, it was working fine with hassbian and when hass.io did not boot at first I tried it with raspbian, also with no errors.

Good you got yours sorted. Unfortunately I could not get any help so after a couple of days I gave up and have stuck with domoticz (same sd card)