HAss.io Node-Red instal

Hi Guys,

I’m new in this community and also new to use HassIO, but i have a question regarding the installation of Node-Red.

I installed the Node-Red third party addon “https://github.com/notoriousbdg/hassio-addons”.

Everything seems to work, i installed the addon and after a while i started the application and in the log i see the following

[INFO] Creating /share/node-red folder
[INFO] Creating default settings
[INFO] Disabling SSL
[INFO] Updating IDE Users
[INFO] Adding IDE User admin
[INFO] Updating HTTP Node User
[INFO] Adding HTTP Node User admin
npm info it worked if it ends with ok
npm info using [email protected]
npm info using [email protected]
npm info lifecycle [email protected]~prestart: [email protected]
npm info lifecycle [email protected]~start: [email protected]

[email protected] start /usr/src/node-red
node $NODE_OPTIONS node_modules/node-red/red.js -v $FLOWS “–userDir” “/share/node-red”
27 Jan 21:32:43 - [info]
Welcome to Node-RED
27 Jan 21:32:43 - [info] Node-RED version: v0.17.5
27 Jan 21:32:43 - [info] Node.js version: v6.11.0
27 Jan 21:32:43 - [info] Linux 4.4.50 arm LE
27 Jan 21:32:45 - [info] Loading palette nodes
27 Jan 21:32:50 - [info] Settings file : /share/node-red/settings.js
27 Jan 21:32:50 - [info] User directory : /share/node-red
27 Jan 21:32:50 - [info] Flows file : /share/node-red/flows.json
27 Jan 21:32:50 - [info] Creating new flow file
27 Jan 21:32:50 - [info] Starting flows
27 Jan 21:32:50 - [info] Started flows
27 Jan 21:32:50 - [info] Server now running at

I think i don’t have to manual download node-red as it is already running, but how can i use node-red? I’m using DuckDNS and SSH Server, but i can’t connect to it from the website i use but then with port 1880.
What should i do to make it work?



Browse to http://hassio.local:1880.

Thanks! that worked for me :grin:

1 Like

@NotoriousBDG have been trying to get node-red to work but get stuck at when I try to configure a node and get the “cannot GET /homeassistant/entities”
appreciate any help with this!

I have tried entering


as the server but no luck

Your router likely doesn’t support NAT loopback. Try using http://hassio/homeassistant as the hostname in Node-Red instead. That will bypass the need for NAT loopback as well as hostname validation since you’re using https.

@NotoriousBDG tried http://hassio/homeassistantbut same problem. if I use https://mydns.duckdns.org:8123 within my network I can access my HASS instance and I am using this for other apps. I really don’t know why this isn’t working.

Try deploying your flow even though you’re getting that error and see if it works. IIRC, I got an error initially, but it went away after the first time I deployed a flow.

Please, I really need help.
I install node Red to try it but after reboot all automations stops to work… i didn’t change anything in the automations.yaml.
I uninstall nod-red but nothing.
I’ve no errors in the debugger.
I also try to cancel all the automations in the file except one really simple but nothing…


I discovered something very strange, if I create an automation with the HA automatic editor, automation works. I tried to rewrite the automation identically to the editor and automation does not work. I believe that, after I have installed node-red, HA wants the id generated automatically by the editor which is the only difference between writing automation manually or writing it with the editor.
Does anyone know how to solve this problem? I do not want to use the automatic editor.