Hass.io on RPI3B+ not reachable on 172.17/16 network

Installed hassos_rpi3-2.12.img multiple times, on two different microSD cards and using two different versions of Etcher, but issues remain:
After first boot of the RPi Hassio seems to complete its update process and is accessible via console (attached keyboard and monitor), but not via the network.
Using the config/network/my-network file I set the eth0 address to (on my 172.17./16 network). I see this Ip address come alive on the (wired) network, and pinging it works for app. 12 seconds only. Then it’s not pingable anymore. The web access (port 8123) never seems to work.
Again: tried several times (reflashed two cards) but issue remains.
172.16 seems to be used internally. Is there a (un)known issue using Hassio on a 172.17/16 network ?

I’m terribly sorry to dig an old thread, but I’m facing this very same issue on a Proxmox install. Did you ever solved it or got an ideia of what happened?


Hi Filipe,

I’ve never solved it, but moved to an Home Assistant install on Ubuntu (Gigabyte Brix X86 PC), which has been working fine for over a year now.
I hope to be moving to an Odroid N2+ install in the next few weeks, since this install is (better) supported.


Well thanks anyway.

As I have a working venv running, I think i’ll leave the hassos for another time.